Содержание

Network Maps. Краткий обзор софта для построения карт сети / Хабр

Статья обновляется по мере узнавания автором о новых продуктах и наличия у того же автора свободного времени на добавление информации.

0. Вводная..


..или немного оффтопа Данная статья родилась только потому, что крайне трудно найти сравнительные характеристики подобного программного обеспечения, а то и просто список, в одном месте. Приходится перелопатить кучу материала, чтобы прийти хоть к какому-то выводу.

В связи с этим я решил немного сэкономить время и силы тех, кого интересует данный вопрос, и собрал максимально возможное, читай осиленное мной, количество систем для network mapping’а в одном месте.

Часть систем, описанных в данной статье, были в свое время испробованы мной лично. Скорее всего, это были неактуальные на данный момент версии. Часть из нижеприведенного я вижу впервые, и информация по ним собиралась исключительно в рамках подготовки данной статьи.

В силу того, что трогал я системы давно, а часть из них не трогал вообще, у меня не осталось ни скриншотов, ни каких-либо примеров. Так что я освежил знания в гугле, вики, на youtube, сайтах разработчиков, там же натырил скриншотов, и в итоге получился вот такой вот обзор.


1. Теория


1.1. Зачем?


Чтобы ответить на вопрос «Зачем?» сначала нужно понять, что же такое «Карта сети». Карта сети – (чаще всего) логико-графико-схематическое представление взаимодействия сетевых устройств и их связи, которое описывает их наиболее значимые параметры и свойства. В наше время часто применяется в связке с мониторингом состояния устройств и системой оповещения. Так вот: затем, чтобы иметь представление о расположении узлов сети, их взаимодействии и связях между ними. В связке с мониторингом мы получаем рабочий инструмент для диагностики поведения и прогнозирования поведения сети.

1.2. L1, L2, L3


Они же Layer 1, Layer 2 и Layer 3 в соответствии с моделью OSI. L1 – физический уровень (провода и коммутация), L2 – уровень физической адресации (mac-адреса), L3 – уровень логической адресации (IP-адреса).

Строить карту L1 смысла, по сути, нет, она логически вытекает из той же L2, за исключением, пожалуй, медиаконвертеров. И то, сейчас существуют медиаконвертеры, которые так же можно отслеживать.

По логике – L2 строит карту сети, основываясь на mac-адресах узлов, L3 – на IP-адресах узлов.

1.3. Какие данные отображать


Тут зависит от решаемых задач и пожеланий. Мне, например, само собой хочется понимать, «жива» ли сама железка, на каком ее порту что «висит» и в каком состоянии порт – up или down. Это может L2. Да и вообще L2 мне кажется наиболее применимой в прикладном смысле топологией карты сети. Но, на вкус и цвет…

Скорость соединения на порту – неплохо, но не критично, если там находится конечное устройство – принтер\ПК. Хорошо бы иметь возможность посмотреть уровень загрузки процессора, количество свободной оперативной памяти и температуру на железке. Но это уже не так просто, тут нужно будет настраивать систему мониторинга, которая умеет читать SNMP и выводить и анализировать полученные данные. Об этом позднее.

По поводу L3 нашел вот такую статью.

1.4. Как?


Можно руками, можно в автоматическом режиме. Если руками – то долго и нужно учитывать человеческий фактор. Если автоматически – то нужно учесть, что все сетевые устройства должны быть «умными», уметь в SNMP и этот SNMP должен быть правильно настроен, чтобы система, которая будет собирать с них данные, смогла эти данные считать.

Вроде не сложно. Но есть подводные камни. Начиная с того, что не каждая система сможет считать с устройства все те данные, которые мы бы хотели видеть, или не все сетевые устройства могут эти данные отдать, и заканчивая тем, что не каждая система умеет сама строить карты сети в автоматическом режиме.

Процесс автоматического формирования карты примерно следующий:

  • система считывает данные с сетевого оборудования
  • на основе данных формирует для каждого порта маршрутизатора таблицу соответствия адресов на портах
  • сопоставляет адреса и имена устройств
  • строит связи порт-порт\устройство
  • отрисовывает все это в виде схемы, «интуитивно понятной» для пользователя

2. Практика


Итак, поговорим теперь о том, с помощью чего можно построить карту сети. Возьмем за отправную точку, что мы хотим, конечно же, максимально автоматизировать данный процесс. Ну, то есть Paint и MS Visio отпадают… хотяяяя… Нет, все-таки отпдают.

Существует специализированный софт, решающий задачу построения карты сети. Какие-то программные продукты могут только предоставить среду для «ручного» добавления картинок со свойствами, отрисовывания связей и запускают «мониторинг» в крайне урезанном виде (жива ли нода, или уже не отвечает). Другие же могут не просто самостоятельно отрисовать схему сети, но и считать кучу параметров с SNMP, оповещать пользователя по SMS в случае поломок, предоставить кучу информации по портам сетевой железки, и все это является лишь частью их функционала (та же NetXMS).

2.1. Продукты


Список далеко не полный, так как существует ну очень много подобного рода софта. Но это все, что выдает гугл по теме (в том числе и англоязычные сайты):

Open Source проекты:

LanTopoLog
Nagios
Icinga
NeDi
Pandora FMS
PRTG
NetXMS
Zabbix
The Dude
nMap
yEd Graph Editor

Платные проекты:

LanState
Total Network Monitor
Solarwinds Network Topology Mapper

UVexplorer
Auvik
AdRem NetCrunch
UserSide

2.2.1. Бесплатное ПО


2.2.1.1. LanTopoLog


Сайт

ПО разработки Юрия Волокитина. Интерфейс простой настолько, насколько это вообще возможно. Софтина поддерживает, скажем так, полуавтоматическое построение сети. Ей нужно «скормить» настройки всех маршрутизаторов (IP, SNMP credentials), далее все произойдет само, а именно будут построены связи между устройствами с указанием портов.

Есть платная и бесплатная версии продукта.

Видео-мануал

2.2.1.2. Nagios


Сайт

Open Source ПО, существует с 1999 года. Система разработана для мониторинга сети, то есть она умеет считывать данные через SNMP и автоматически строить карту сети, но так как это ее не основная функция, то делает она это весьма… странно… Для построения карт используется NagVis.

Видео-мануал

2.2.1.3. Icinga


Сайт

Icinga – это Open Source система, которая в свое время отпочковалась от Nagios. Система позволяет автоматически строить карты сети. Проблема лишь в том, что карты она строит при помощи аддона NagVis, который был разработан под Nagios, так что будем считать, что в качестве построения карты сетей эти две системы идентичны.

Видео- мануал

2.2.1.4. NeDi


Сайт

Умеет автоматически обнаруживать ноды в сети, и на основе этих данных строить карту сети. Интерфейс довольно простой, есть мониторинг состояния по SNMP.

Есть бесплатная и платная версии продукта.

Видео-мануал

2.2.1.5. Pandora FMS


Сайт

Умеет в автообнаружение, автопостроение сети, SNMP. Приятный интерфейс.

Есть бесплатная и платная версии продукта.

Видео-мануал

2.2.1.6. PRTG


Сайт

ПО не умеет в автоматическое построение карты сети, только перетаскивание картинок вручную. Но при этом умеет мониторить состояние устройств через SNMP. Интерфейс оставляет желать лучшего, на мой субъективный взгляд.

30 дней — полный функционал, потом — «бесплатная версия».

Видео-мануал

2.2.1.7. NetXMS


Сайт

NetMXS – это в первую очередь Open Source система мониторинга, построение карты сети – побочная функция. Но реализована она достаточно аккуратно. Автоматическое построение на основе автообнаружения, мониторинг нод по SNMP, умеет отслеживать состояние портов маршрутизаторов и другую статистику.

Видео-мануал

2.2.1.8. Zabbix


Сайт

Zabbix – это тоже Open Source система мониторинга, причем более гибкая и мощная, чем NetXMS, но карты сети он умеет строить только в ручном режиме, а вот мониторить может практически любые параметры маршрутизаторов, сбор которых только можно настроить.

Видео-мануал

2.2.1.9 The Dude


Сайт

В целом не сложная бесплатная утилитка, заточенная под работу с маршрутизаторами Mikrotik. Позволяет управлять устройствами, не выходя из программы. Так же может работать и с устройствами других вендоров, но об этом не заявлено официально, и списка поддерживаемых устройств я не нашел. На мой вкус интерфейс не самый приятный, но работать в нем можно.

Видео-мануал

2.2.1.10. nMap


Сайт

Основной функционал данного ПО — сканирование безопасности сети. Но на базе собранных данных система может построить и карту сети, правда, мониторить в привычном смысле она не может (насоклько я понял). Зато выводит исчерпывающую информацию на карту.

Видео-мануал

2.2.1.11. yEd Graph Editor


Сайт

Данное ПО не умеет автоматически строить карты сети, но к нему можно написать собственные модули на Python. Готового модуля для решения данной задачи я не нашел. У объектов есть свойства, в которые можно добавить ссылки для ускорения перехода на объекты. Так же можно настроить мониторинг.

Вообще, это ПО предназначено не только для отрисовки карт сети, оно имеет более широкий функционал.

Канал на YouTube, от создателей, где можно найти и туториалы по работе, и описание функций. Канал на английском языке.

2.2.2. Платное ПО


2.2.2.1. LanState


Сайт

Платное ПО, позволяющее автоматически просканировать топологию сети и на базе обнаруженного оборудования построить карту сети. Позволяет мониторить состояние обнаруженных устройств только по up\down самой ноды.

Видео-мануал

2.2.2.2. Total Network Monitor


Сайт

Платное ПО, которое не умеет автоматически строить карту сети. Не умеет даже автоматически обнаруживать ноды. По-сути это тот же Visio, только ориентированный на сетевую топологию. Позволяет мониторить состояние обнаруженных устройств только по up\down самой ноды.

Черт! Я же писал выше, что от Paint и Visio мы отказываемся… Ладно, пусть будет.

Видео-мануал я не нашел, да он и не нужен… Программка так себе.

2.2.2.3. Solarwinds Network Topology Mapper


Сайт

Платное ПО, есть триал-период. Может автоматически просканировать сеть и самостоятельно составить карту по заданным параметрам. Интерфейс довольно простой и приятный.

Видео-мануал

2.2.2.4. UVexplorer


Сайт

Платное ПО, 15-тидневный триал. Умеет автообнаружение и автоматическое отрисовывание карты, мониторинг девайсов только по состоянию up/down, то есть через пинг устройства.

Видео-мануал

2.2.2.5. Auvik


Сайт

Довольно симпатичная платная программка, умеет в автообнаружение и мониторинг сетевых устройств.

Видео-мануал

2.2.2.6. AdRem NetCrunch


Сайт

Платная софтина с 14ти дневным триалом. Умеет в автоопределение и автопостроение сети. Интерфейс восторгов не вызвал. Умеет так же в SNMP мониторинг.

Видео-мануал

2.2.2.7. UserSide


Сайт

По-сути, это мощная ERP-система для провайдеров. Презентация с возможностями вот тут есть. Умеет мониторить все, что только можно и как только можно. Но это дорогой монстр, мощности которого для простого построения карты сети слишком велики… Но… Карты же он рисует…

Видео-мануал

3. Табличка сравнения


Как оказалось — придумать актуальные и важные параметры для сравнения систем и при этом уместить их в одну маленькую табличку — достаточно сложно. У меня родилось вот это:

*Параметр «User Friendly» является крайне субъективным, и я это понимаю. Но как еще описать «топорность и нечитаемость» я не придумал.

**«Мониторинг не только сети» подразумевает под собой работу системы как «систему мониторинга» в привычном понимании этого термина, то есть возможность считывать метрики с ОС, хостов виртуализации, получать данные от приложений в гостевых ОС и т.д.

4. Личное мнение


Из личного опыта — использовать ПО отдельно для мониторинга сети я не вижу смысла. Мне больше импонирует мысль использовать систему мониторинга всего и вся с возможностью построения карты сети. У Zabbix с этим дело обстоит… трудно. Nagios и Icinga — тоже. И только NetXSM порадовала в этом плане. Хотя, если заморочиться и сделать карту в Zabbix, то это выглядит даже более перспективным, нежели NetXMS. Есть еще Pandora FMS, PRTG, Solarwinds NTM, AdRem NetCrunch, и скорее всего куча еще чего, не вошедшего в данную статью, но я их видел только на картинках и в видео, так что ничего сказать о них не могу.

По поводу NetXMS была написана статья с небольшим обзором возможностей системы и небольшой how to.

P.S.:


Если я где-то ошибся, а я скорее всего ошибся, будьте добры, исправьте в комментариях, я подправлю статью, дабы тем, кому эта информация будет полезной, не пришлось все перепроверять на собственном опыте.

Спасибо.

Чем рисовать схему сети? ~ NetSkills

У меня довольно часто спрашивают: «Чем вы рисуете сети?». Причем вопрос на столько частый, что я даже решил написать статью на эту тему. Ниже я вкратце расскажу про два инструмента, которыми чаще всего пользуюсь. Также попробую сформулировать мысль, когда и каким инструментом лучше пользоваться.

1) Microsoft Visio


Это наверно первое, что может придти в голову. Это фактически стандарт для рисования схем. Тут и не поспоришь. Инструмент действительно очень функциональный. Более того, иногда при приеме молодых инженеров на работу, некоторые компании чуть ли не обязательным условием ставят «умение работать в Visio». Я бы добавил, что если вы рисуете схему для какой-то компании, то вы обязаны использовать Visio. Скорее всего им захочется иметь возможность вносить правки и тут уже никто не будет разбираться, что за программу вы использовали. Большинство компаний хотят видеть свои схемы именно в Visio-формате.

Большой плюс Visio — огромное количество дополнительных иконок и фигур. Многие вендоры (Cisco, VMware, Check Point, Fortinet и т.д.) сами делают эти иконки для Visio и выкладывают их в открытый (либо закрытый) доступ. К примеру иконки Cisco можно посмотреть здесь.

Несколько скриншотов программы:

C недавнего времени доступна online версия:

Есть один минус — утилита платная. Я знаю, что это мало кого останавливает, но все же. Плюс, как мне кажется, для рядовых задач этот инструмент слишком «мощный». Когда вам нужно быстро «накидать» простенькую схему, то можно вполне обойтись более простым инструментом…

2) Draw.io

На текущий момент это мой любимый инструмент для отрисовки схем. Схемы я затем использую в своих книгах, курсах, статьях и т.д. Изначально это online-платформа которая работает из любого браузера:

Главное удобство — этот сервис интегрируется с Google Drive, а значит все созданные вами схемы будут в одном месте и доступны в любое время. Сам интерфейс и функционал очень напоминает Visio, поэтому особых проблем в навигации не возникнет. Сервис — бесплатный.

Относительно недавно была представлена и десктопная версия. Доступно несколько операционных систем:

Главный минус — маленький набор иконок. Cisco-фигуры хоть и присутствуют, но довольно старого дизайна. При этом нет никаких проблем, если добавлять иконки в png формате.

Хотел бы повториться, что я использую данный сервис исключительно для «своих» схем. Если мне нужно отправить схему заказчику, то я использую только Visio.

Дополнительные инструменты

Могу порекомендовать еще пару сервисов, однако сам ими не пользуюсь:

НОУ ИНТУИТ | Лекция | Полезные сетевые программы и утилиты

Аннотация: В лекции мы рассмотрим сетевые программы для создания схем локальных сетей, администрирования, мониторинга и инвентаризации компьютерных сетей. Точнее — две программы этого класса сетевых программ, предназначенные, главным образом, для системных администраторов, а также для студентов, делающих курсовые проекты и дипломы по компьютерным сетям. Речь идет о программах 10 Страйк: Схема Сети и EDraw Network Diagrammer. Нельзя сказать, что мы изучим эти программы досконально, скорее всего, это будет небольшой обзор программ их возможностей с целью заинтересовать пользователя для их дальнейшего практического изучения.

1. Создание схем локальных сетей в программе 10 Страйк: Схема Сети

10-Страйк: Схема Сети — программа создания схем локальных сетей, позволяющая обнаружить сетевые устройства и поместить их на карту-схему. Сайт разработчиков — http://www.10-strike.com/rus/download.shtml. Программа содержит библиотеку значков сетевых устройств, что позволяет в ней рисовать схемы для курсовика или диплома. Если в сети поддерживается протокол SNMP, то программа нарисует связи между устройствами автоматически. Иначе говоря, в этой программе можно создать схему локальной сети в ручном или автоматическом режиме. Программа сканирует топологию сети и все сетевые устройства отображает графически. Остаётся только отредактировать схему сети – дорисовать недостающие связи, нанести надписи, применить желаемый цвет для рисунков.

Практика работы в программе

При первом запуске автоматически запускается Мастер создания новой карты сети ( рис. 8.1). В процессе работы Мастера создания карты сети выберите нужный вариант поиска компьютеров:

  • Сканирование диапазона IP-адресов. Если у вас большая коммутируемая сеть, то рекомендуется использовать этот способ сканирования. Но он довольно продолжителен по времени.
  • Импорт из сетевого окружения. Данный способ работает несколько быстрее, причем программа автоматически разобьет найденные компьютеры по их рабочим группам или доменам.
Запуск Мастера создания новой карты сети
Рис. 8.1. Запуск Мастера создания новой карты сети

Нажимаем на кнопку Далее ( рис. 8.2).

Задаем диапазон сканирования локальной сети
Рис. 8.2. Задаем диапазон сканирования локальной сети

Нажимаем на кнопку Далее ( рис. 8.3).

Задаем параметры сканирования сети
Рис. 8.3. Задаем параметры сканирования сети

Нажимаем на кнопку Далее ( рис. 8.4).

Отбор ПК для их помещения на карту сети
Рис. 8.4. Отбор ПК для их помещения на карту сети

Нажимаем на кнопку Далее ( рис. 8.5).

Окно сохранения карты сети в файл
Рис. 8.5. Окно сохранения карты сети в файл

Нажимаем на кнопку Готово ( рис. 8.6).

Карта сети построена
Рис. 8.6. Карта сети построена

Теперь, при желании, вы ее можете отредактировать ( рис. 8.7).

Карта сети отредактирована
Рис. 8.7. Карта сети отредактирована

Примечание

Интернет заполнен большим количеством опасных программ, активно желающих проникнуть в систему вашего компьютера. Для защиты операционной системы от подобных угроз и был создан сетевой экран (брандмауэр или файрвол). Главным назначением этой программы, которая запрещает или ограничивает им доступ в Интернет, является управление сетевой активностью приложений. Многие программные продукты сразу после установки на ПК самостоятельно, без вашего ведома, начинают посещать Интернет и обновляться. Если будет использоваться брандмауэр, то подобная активность точно будет замечена пользователем и будет им контролироваться.

Как создавать понятные логические (L3) схемы сети / Хабр

Cамая большая проблема, с которой я сталкиваюсь при работе с сетями предприятий — это отсутствие чётких и понятных логических схем сети. В большинстве случаев я сталкиваюсь с ситуациями, когда заказчик не может предоставить никаких логических схем или диаграмм. Сетевые диаграммы (далее L3-схемы) являются чрезвычайно важными при решении проблем, либо планировании изменений в сети предприятия. Логические схемы во многих случаях оказываются более ценными, чем схемы физических соединений. Иногда мне встречаются «логически-физически-гибридные» схемы, которые практически бесполезны. Если вы не знаете логическую топологию вашей сети, вы слепы. Как правило, умение изображать логическую схему сети не является общим навыком. Именно по этой причине я пишу эту статью про создание чётких и понятных логических схем сети.

Какая информация должна быть представлена на L3-схемах?

Для того, чтобы создать схему сети, вы должны иметь точное представление о том, какая информация должна присутствовать и на каких именно схемах. В противном случае вы станете смешивать информацию и в итоге получится очередная бесполезная «гибридная» схема. Хорошие L3-схемы содержат следующую информацию:
  • подсети
    • VLAN ID (все)
    • названия VLAN’ов
    • сетевые адреса и маски (префиксы)

  • L3-устройства
    • маршрутизаторы, межсетевые экраны (далее МСЭ) и VPN-шлюзы (как минимум)
    • наиболее значимые серверы (например, DNS и пр.)
    • ip-адреса этих серверов
    • логические интерфейсы

  • информацию протоколов маршрутизации

Какой информации НЕ должно быть на L3-схемах?

Перечисленной ниже информации не должно быть на сетевых схемах, т.к. она относится к другим уровням [модели OSI, прим. пер.] и, соответственно, должна быть отражена на других схемах:
  • вся информация L2 и L1 (в общем случае)
  • L2-коммутаторы (может быть представлен только интерфейс управления)
  • физические соединения между устройствами

Используемые обозначения

Как правило, на логических схемах используются логические символы. Большинство из них не требуют пояснений, но т.к. я уже видел ошибки их применения, то позволю себе остановиться и привести несколько примеров:
  • Подсеть, представленная как трубка или линия:

  • VRF или другая не известная точно зона представляется в виде облака:


Какая информация необходима для создания L3-схемы?

Для того, чтобы создать логическую схему сети, понадобится следующая информация:
  • Схема L2 (или L1) — представление физических соединений между устройствами L3 и коммутаторами
  • Конфигурации устройств L3 — текстовые файлы либо доступ к GUI, и т.д.
  • Конфигурации устройств L2 — текстовые файлы либо доступ к GUI, и т.д.
Пример

В данном примере мы будем использовать простую сеть. В ней будут присутствовать коммутаторы Cisco и МСЭ Juniper Netscreen. Нам предоставлена схема L2, также как и конфигурационные файлы большинства представленных устройств. Конфигурационные файлы пограничных маршрутизаторов ISP не предоставлены, т.к. в реальной жизни такую информацию ISP не передаёт. Ниже представлена L2-топология сети:

А здесь представлены файлы конфигурации устройств. Оставлена только необходимая информация:

asw1

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.11 255.255.255.128
!
ip default-gateway 192.168.10.1


asw2

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.12 255.255.255.128
!
ip default-gateway 192.168.10.1


asw3

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.13 255.255.255.128
!
ip default-gateway 192.168.10.1


csw1

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.29 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.2 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.130 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.2 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.130 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.2 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17


csw2

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.30 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.3 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.131 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.3 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.131 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.3 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17


fw1

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.2
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.18
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12


fw2

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.3
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.19
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12


outsw1

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr1
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.50 255.255.255.240
!
ip default-gateway 10.0.0.49


outsw2

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr2
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.51 255.255.255.240
!
ip default-gateway 10.0.0.49

Сбор информации и её визуализация

Хорошо. Теперь, когда мы имеем всю необходимую информацию, можно приступать к визуализации.
Процесс отображения шаг за шагом

  1. Сбор информации:
    1. Для начала откроем файл конфигурации (в данном случае ASW1).
    2. Возьмём оттуда каждый ip-адрес из разделов интерфейсов. В данном случае есть только один адрес (192.168.10.11) с маской 255.255.255.128. Имя интерфейса — vlan250, и имя vlan 250 — In-mgmt.
    3. Возьмём все статические маршруты из конгфигурации. В данном случае есть только один (ip default-gateway), и он указывает на 192.168.10.1.

  2. Отображение:
    1. Теперь давайте отобразим информацию, которую мы собрали. Во-первых, нарисуем устройство ASW1. ASW1 является коммутатором, поэтому используем символ коммутатора.
    2. Нарисуем подсеть (трубку). Назначим ей имя In-mgmt, VLAN-ID 250 и адрес 192.168.10.0/25.
    3. Соединим ASW1 и подсеть.
    4. Вставляем текстовое поле между символами ASW1 и подсети. Отобразим в нём имя логического интерфейса и ip-адрес. В данном случае имя интерфейса будет vlan250, и последний октет ip-адреса — .11 (это является общей практикой — отображать только последний октет ip-адреса, т.к. ip-адрес сети уже присутствует на схеме).
    5. Также в сети In-mgmt есть другое устройство. Или, как минимум, должно быть. Нам ещё неизвестно имя этого устройства, но его IP-адрес 192.168.10.1. Мы узнали это потому, что ASW1 указывает на этот адрес как на шлюз по-умолчанию. Поэтому давайте отобразим это устройство на схеме и дадим ему временное имя «??». Также добавим его адрес на схему — .1 (кстати, я всегда выделяю неточную/неизвестную информацию красным цветом, чтобы глядя на схему можно было сразу понять, что на ней требует уточнения).


На этом этапе мы получаем схему, подобную этой:

Повторите этот процесс шаг за шагом для каждого сетевого устройства. Соберите всю информацию, относящуюся к IP, и отобразите на этой же схеме: каждый ip-адрес, каждый интерфейс и каждый статический маршрут. В процессе ваша схема станет очень точной. Убедитесь, что устройства, которые упомянуты, но пока неизвестны, отображены на схеме. Точно так же, как мы делали ранее с адресом 192.168.10.1. Как только вы выполните всё перечисленное для всех известных сетевых устройств, можно начать выяснение неизвестной информации. Вы можете использовать для этого таблицы MAC и ARP (интересно, стоит ли писать следующий пост, рассказывающий подробно об этом этапе?).

В конечном счёте мы будем иметь схему наподобие этой:

Заключение

Нарисовать логическую схему сети можно очень просто, если вы обладаете соответствующими знаниями. Это продолжительный процесс, выполняемый вручную, но это отнюдь не волшебство. Как только у вас есть L3-схема сети, достаточно нетрудно поддерживать её в актуальном состоянии. Получаемые преимущества стоят приложенных усилий:
  • вы можете планировать изменения быстро и точно;
  • решение проблем занимает гораздо меньше времени, чем до этого. Представим, что кому-то нужно решить проблему недоступности сервиса для 192.168.0.200 до 192.168.1.200. После просмотра L3-схемы можно с уверенностью сказать, что МСЭ не является причиной данной проблемы.
  • Вы можете легко соблюдать корректность правил МСЭ. Я видел ситуации, когда МСЭ содержали правила для трафика, который никогда бы не прошёл через этот МСЭ. Этот пример отлично показывает, что логическая топология сети неизвестна.
  • Обычно как только L3-схема сети создана, вы сразу заметите, какие участки сети не имеют избыточности и т.д. Другими словами, топология L3 (а также избыточность) является такой же важной как избыточность на физическом уровне.

5 бесплатных инструментов для создания диаграммы сети

Когда речь идет о программах для создания диаграмм, де-факто стандартом является Microsoft Visio. Но с учетом того, что версия Standard edition стоит около 300 долларов США на 1 ПК, а версия «Про» вдвое больше, некоторые захотят найти бесплатную альтернативу этому UML редактору.

В этой статье мы рассмотрим пять лучших бесплатных и простых в использовании инструментов для создания диаграмм сети.

Draw.io


Бесплатное облачное программное обеспечение для создания диаграмм онлайн. Сформированные диаграммы можно сохранить на Google Диск, в Dropbox, OneDrive или на собственное устройство. А также экспортировать их в форматы PNG, SVG, HTML, PDF или XML.

Нажмите кнопку «Больше фигур», расположенную в левой части экрана, чтобы выбрать другие фигуры, обозначающие сетевые устройства, из предустановленных категорий. С помощью «Электронного блокнота» можно добавлять собственные изображения, перетаскивая их, импортируя из файлов или указывая URL-адрес изображения.

LibreOffice Draw


Draw является частью пакета LibreOffice, альтернативы Open Office и Microsoft Office. Сточки зрения функционала Draw похож на Visio, он предлагает возможность создавать базовые или сложные диаграммы: от блок-схем и схем корпоративной сети до 3D-диаграмм.

LibreOffice Draw работает на Windows, Linux и Mac OS X.

Совет. LibreOffice Portable позволяет запускать любые инструменты с USB-устройств, локального жесткого диска или из облака.

Чтобы начать работу с редактором UML диаграмм, нужно загрузить и установить пакет иконок топологии сети, доступный в виде расширения. К популярным расширениям относятся VRT Network Equipment и Cisco Network Topology Icons.

Чтобы установить расширение, перейдите в Инструменты — Диспетчер расширений — Добавить, а затем выберите загруженный файл и он автоматически добавится в список расширений.

Если есть собственные иконки или изображения, которые вы хотите использовать в диаграмме, их можно добавить в галерею. Откройте «Галерею», кликнув иконку в правой стороне экрана, или перейдите в меню Вставка — Мультимедиа — Галерея клипартов. Здесь можно создать папку «Новая тема» и добавить в нее свои изображения или иконки.

LucidChart Free


Интерактивный облачный инструмент, который позволяет создавать основные диаграммы сети с использованием интуитивно понятного и функционального интерфейса. Используя LucidChart, можно взаимодействовать с другими пользователями, позволяя им просматривать, редактировать и комментировать документ.

Зарегистрировав бесплатную учетную запись, вы получите доступ ко всему, что нужно для создания основных сетевых диаграмм непосредственно из браузера. У бесплатной учетной записи UML редактора есть некоторые ограничения. В том числе ограничение по количеству объектов в одной диаграмме (максимум 60). Также нельзя экспортировать диаграммы в формат Visio и просматривать историю изменений.

При создании нового документа кликните по иконке, расположенной рядом с фигурами слева, чтобы добавить в библиотеку другие фигуры. Можно поискать в Сети другие фигуры, изображения или иконки; импортировать собственные изображения, нажав на иконку лупы, расположенную в верхней левой части экрана.

Dia Diagram Editor


Инструмент с открытым исходным кодом для создания UML-диаграмм, блок-схем, сетевых архитектур и т. д. Он поставляется с тысячами объектов, которые помогут создать профессиональные диаграммы.

Dia Diagram Editor работает на Windows, Linux и Mac OS X.

Чтобы импортировать на диаграмму собственные изображения, нажмите кнопку «Изображение», расположенную в левой верхней части экрана, а затем дважды кликните в любом месте диаграммы. На экране появится окно, в котором можно просмотреть доступные для вставки изображения.

yEd Graph Editor


Это редактор UML диаграмм с открытым исходным кодом для создания диаграмм, который можно использовать для создания схем проекта сети, блок-схем и т. д. Благодаря простому и чистому дизайну yEd упрощает разработку основных диаграмм сети и экспорт их в популярные форматы, такие как PDF, SWF, SVG, PNG и HTML.

YEd работает на Windows, Linux и Mac OS X.

Кликните правой кнопкой мыши в любом месте панели «Палитра» и выберите пункт «Панель управления». Здесь можно импортировать палитры и трафареты Visio. Также можете использовать Icon Finder для поиска бесплатных иконок для диаграмм. Чтобы добавить собственное изображение, просто перетащите его в интерфейс yEd.

Проектирование ЛВС с помощью программы CAD5D

Онлайн-программа CAD5D используется для проектирования локальных компьютерных сетей предприятия и административных зданий. С ее помощью можно разработать подробные поэтажные планы здания, разместить необходимые абонентские точки и основные узлы управления, а также рассчитать необходимые длины всех кабелей. Программа позволяет создать полную проектную рабочую документацию, все необходимые спецификации оборудования и материалов, необходимых для разработки компьютерной сети. Программа CAD5D имеет модуль интеграции с программами САПР, поддерживает формат dwg. Эта функция существенно облегчает задачи проектировщику по разработке проекта компьютерных сетей, а наличие кабельного журнала сводит ошибки при выборе кабельной продукции к минимуму.

Какие задачи можно решить с помощью CAD5D

  • Разработать полный проект компьютерной сети предприятия с учетом вертикальной и горизонтальной иерархии;
  • В онлайн режиме подобрать необходимое оборудование и кабельную продукцию;
  • Подготовить рабочие чертежи к печати;
  • Можно визуально отобразить расположение абонентских точек, беспроводных устройств и мест расположения активного оборудования в 3D редакторе;
  • Разработать полный сметный расчет ЛВС с учетом региона и расценок на работы;
  • Создать отдельную базу материалов и оборудования под конкретный проект локальной компьютерной сети, а также сохранить ее на сервере для дальнейшего использования.

Ключевые преимущества программы CAD5D

  • Мощное графическое ядро с большими функциональными возможностями;
  • Это онлайн-программа, для ее работы не нужна инсталляция, поэтому разработку локальных компьютерных сетей можно выполнять сразу на объекте заказчика через интернет;
  • Базы материалов, оборудования хранятся на сервере;
  • Все разработанные проекты хранятся на сервере и к ним есть постоянный доступ через интернет;
  • Можно сделать полный расчет локальной сети и подобрать оптимальное оборудование под договорную цену;
  • Программа самостоятельно рассчитает параметры затухания в кабельных линиях с учетом длины передачи данных;
  • При создании кабельного журнала автоматически будут учтены монтажные резервы на коммутацию оборудования, промежуточных патч-панелей и абонентских розеток.

Особенности проектирования локальной сети предприятия

  • Чем больше абонентов прямого включения, тем ниже будет скорость передачи данных, о чем заказчики часто забывают;
  • При разработке ЛВС нужно учитывать уровень затухания в кабелях, а также наличие возможных наводок. Но далеко не всегда использование дорогих экранированных кабелей себя оправдывает;
  • При проектировании локальной компьютерной сети горизонтальной и вертикальной иерархии проектировщик забывает о необходимом монтажном резерве, что в результате приводит к большим финансовым потерям для исполнителя монтажных работ;
  • Нельзя брать за основу проекта техническое задание Заказчика. Заказчик не является профессиональным проектировщиком и не несет ответственности за качественную реализацию проекта.
    Он может только сказать, сколько будет ориентировочно проводных и беспроводных абонентов, а также скорость интернета, которую обеспечивает провайдер;
  • При проектировании нужно обязательно учесть требования заказчика в соответствии с техническим заданием, а также провести предварительный расчет компьютерных сетей исходя от реальной ситуации на объекте.
  • Если проектировщик выполняет проект нового строительства, тогда он должен учесть возможные подвесные потолки, кабельные каналы и шахты, т.д.;
  • Техническое решение принимает проектировщик и ему нужна полнофункциональная программа для проектирования и сметных расчетов. CAD5D для таких целей подойдет идеально, ведь можно вносить изменения в проект и смету онлайн при внесении изменений непосредственно в схемы и поэтажные планы.

Ключевые преимущества программы для проектирования локальной сети CAD5D

  • Можно прямо на объекте внести изменения в рабочую документацию в режиме реального времени. Программа смету пересчитает автоматически;
  • Можно импортировать файлы dwg c AutoCad, ArchiCad с дальнейшим изменением или редактированием;
  • При проектировании ЛВС предприятия можно создать собственную базу данных;
  • Предусмотрен сметный расчет ЛВС в соответствии со строительными нормами конкретной страны;
  • Программа для проектирования ЛВС CAD5D в автоматическом режиме подбирает оптимальную кабельную продукцию из существующей базы, а проектировщик уже решает, можно такой кабель использовать при расчете компьютерной сети или нет;
  • При проектировании оптических компьютерных сетей CAD5D использует расценки на розварку оптики исключительно по количеству предусмотренных проектом волокон.

Организация работы программы

  • Есть постоянный доступ к чертежам и пояснительной записке к проекту;
  • Предусмотрен импорт готовых поэтажных планов;
  • Подбираются кабели, активное и пассивное оборудование с готовых или импортированных баз;
  • Проектировщик распечатывает полностью готовый проект, который может содержать сертификаты соответствия, если они есть в базе программы.

Какие документы для расчета ЛВС программа формирует автоматически

  • Поэтажные планы с расположением оборудования и кабельных сетей;
  • Структурную схему подключения активного и промежуточного оборудования;
  • Расчет затухания по каждой кабельной трассе;
  • Кабельный журнал с учтенным монтажным резервом;
  • Спецификация оборудования, кабельной продукции и материалов;
  • Сметный расчет компьютерных сетей;
  • При необходимости, расчет нагрузки на каждый порт коммутатора или максимальную скорость передачи данных через «витую» пару или оптическое волокно.

НОУ ИНТУИТ | Лекция | Программа для изучения компьютерных сетей Netemul

Аннотация: Бесплатная программа Netemul была создана в учебных целях и служит для визуализации работы компьютерных сетей, для облегчения понимания происходящих в ней процессов. Программа одинаково хорошо работает как в ОС Windows XP, так и в ОС Windows 7.

Интерфейс программы

Для начала установим программу, запустим и русифицируем ее командой Сервис-Настройки ( рис. 11.1).

Русифицируем интерфейс программы
Рис. 11.1. Русифицируем интерфейс программы

В главном окне программы все элементы размещаются на рабочей области (на Сцене). На всей свободной области сцены, размеченной сеткой можно ставить устройства, при этом они не должны пересекаться. На Панели устройств размещены все необходимые для построения сети инструменты, а так же кнопка отправки сообщений и Запустить/Остановить. На Панели параметров расположены свойства объектов. Для выделенного объекта появляются только те свойства, которые характерны для него ( рис. 11.2).

l
l Интерфейс программы Netemul
Рис. 11.2. Интерфейс программы Netemul

Пример 1. Строим сеть из двух ПК и коммутатора

Для начального знакомства с программой давайте построим простейшую локальную сеть и посмотрим, как она работает. Для этого выполните команду Файл-Новый и нарисуйте схему сети как на рис. 11.3.

Схема из двух ПК и концентратора
Рис. 11.3. Схема из двух ПК и концентратора

После рисования двух ПК и концентратора создадим их соединение ( рис. 11.4).

Инструмент создания соединений сетевых устройств
Рис. 11.4. Инструмент создания соединений сетевых устройств

В процессе рисования связей между устройствами вам потребуется выбрать соединяемые интерфейсы и нажать на кнопку Соединить ( рис. 11.5 и 6).

Выбор начальных настроек соединения
Рис. 11.5. Выбор начальных настроек соединения Соединение устройств произведено
Рис. 11.6. Соединение устройств произведено

Теперь настроим интерфейс (сетевую карту) на наших ПК ее – рис. 11.6 и рис. 11.7.

Добавляем интерфейс
Рис. 11.6. Добавляем интерфейс Вводим IP адрес и маску сети
Рис. 11.7. Вводим IP адрес и маску сети

Примечание

Обратите внимание: после того, как вы напишете 192.168.0.1 маска появляется автоматически. После нажатия на кнопки Применить и ОК – появляется анимация движущихся по сети пакетов информации.

Все — сеть создана и настроена. Отравляем данные по протоколу TCP ( рис. 11.8 и рис. 11.9).

Кнопка Отправить данные
Рис. 11.8. Кнопка Отправить данные Выбор протокола
Рис. 11.9. Выбор протокола

Если вы где-то ошиблись, то появится соответствующее сообщение, а если все верно – то произойдет анимация движущихся по сети пакетов ( рис. 11.10).

Движение пакетов по сети
Рис. 11.10. Движение пакетов по сети

И еще один момент. По умолчанию каждый ПК имеет одну сетевую карту, но их может быть и несколько. Для того, чтобы добавить для ПК адаптер нужно щелкнуть на нем правой кнопкой мыши и выбрать пункт меню Интерфейсы. В результате откроется следующее диалоговое окно ( рис. 11.11).

Диалоговое окно работы с сетевым интерфейсом ПК
Рис. 11.11. Диалоговое окно работы с сетевым интерфейсом ПК

Нажимаем на кнопку Добавить, выбираем тип нового адаптера, нажимаем ОK, и у нас есть еще один интерфейс. В качестве примера на рис. 11.12 изображен ПК, имеющий три сетевых карты.

В этом ПК установлены адаптеры eth0-eth4
Рис. 11.12. В этом ПК установлены адаптеры eth0-eth4

Примечание

Каждый сетевой интерфейс (сетевой адаптер) имеет свой собственный mac-адрес. В программе Netemul в строке «Mac-адрес» можно задать новый адрес, но по умолчанию, при создании интерфейса, ему автоматически присваивается этот уникальный номер.

Настольная программа

Network Diagram — создание красивой сетевой схемы

Программа для рисования сетевых диаграмм на рабочем столе позволяет создавать сетевые диаграммы с молниеносной скоростью и может работать как на ПК, так и на Mac. Он предлагает пожизненное обслуживание с дешевым разовым платежом.

Нужно найти настольную программу для построения схемы сети? Попробуйте это автоматическое создание схем сети с множеством практических функций. Это определенно стоит пробовать.

Network Diagram Desktop Program

Видео-демонстрация — Как создать сетевую диаграмму

Загрузить ПО для построения схемы сети:

Настольное программное обеспечение Easy Network Diagram — создание привлекательной сетевой диаграммы

Настольное программное обеспечение Edraw Network Diagram предлагает эффективный инструментарий для создания сетевых диаграмм профессионального качества на Mac, Windows и Linux.Он помогает визуально представить сетевые узлы и соединения с помощью графики, которая упрощает понимание.

Многим пользователям нравится этот конструктор сетевых диаграмм из-за его интерфейса в стиле Microsoft. Начните работу так же быстро, как молния, с готовыми символами схем сети и готовыми к использованию шаблонами. Гибкие возможности перетаскивания позволяют легко создавать и компоновку вашей сетевой диаграммы. Он также предлагает различные возможности экспорта, что упрощает обмен файлами в необходимом формате.

Особенности программы оптимальной сетевой диаграммы

  • Кросс-платформенное приложение, работающее в Windows, Linux и Mac OS.
  • Простой и быстрый инструмент построения диаграмм для создания простой сетевой диаграммы в течение 10 минут или меньше и сложной сетевой диаграммы в любой степени.
  • Включает тысячи готовой сетевой графики и шаблонов для продуктов Cisco, AWS и сетевых устройств, таких как компьютеры, серверы, концентраторы, коммутаторы, принтеры, мэйнфреймы, маршрутизаторы, кабели, факсы и многое другое.
  • Поддержка печати WYSIWYG.
  • Можно экспортировать в PDF, Word, Excel, PPT, Html, Visio, SVG, PNG, EPS и другие.
  • Поддержка многостраничной сетевой схемы.
  • Полностью совместим с программами Microsoft.

Примеры сетевых диаграмм

В программе есть отличные примеры сетевых диаграмм и шаблоны, которые вы можете использовать, чтобы начать свой дизайн.Примеры можно редактировать. Если вам нужен один из следующих примеров, просто щелкните изображение и загрузите исходный файл.

Сеть ЦОД

Сеть видеонаблюдения

Топология сети

Он четко показывает структуру сети центра обработки данных.

Схема сети видеонаблюдения показывает, как камеры видеонаблюдения устанавливаются и подключаются.

Схема сетевой топологии показывает расположение различных элементов компьютерной сети.

Другие источники
,Программное обеспечение для обнаружения топологии сети и создания диаграмм

Изучите топологию вашей локальной сети, задокументируйте схему LAN и легко создавайте диаграммы с помощью нашей программы построения диаграмм сети.

10-Strike Схема сети это мощное программное обеспечение для обнаружения топологии сети для Windows для быстрого создания графических векторных диаграмм и , экспортирующих их в Microsoft Visio , векторные или растровые изображения. Программа сканирует вашу локальную сеть, обнаруживает топологию сети , автоматически строит графическую схему сети (карту), отображает компьютеры и устройства разных типов в виде специальных значков и устанавливает связи между устройствами (если ваши коммутаторы поддерживают протокол SNMP ).

Создавайте и сохраняйте сетевые диаграммы в популярных графических форматах, копируйте и вставляйте диаграммы в документы в виде графических изображений, распечатывайте их или экспортируйте в Microsoft Visio для дальнейшей обработки.

Сценарии использования сетевой схемы 10-Strike:

  • Вам нужна сетевая диаграмма вашей локальной сети для документации?
    10-Strike Network Diagram Screenshots Наша программа определит топологию вашей сети, и вы сможете легко нарисовать сетевые диаграммы, используя наш мощный редактор сетевых диаграмм.
  • Вы новый администратор и хотите проанализировать топологию своей локальной сети?
    10-Strike Network Diagram Screenshots Начните обнаруживать свою сеть и создавать векторные диаграммы с помощью нашей программы!
  • Вы хотите нарисовать карту сети, но не знаете, как работать с MS Visio и другими сложными продуктами?
    10-Strike Network Diagram Screenshots Попробуйте нашу программу бесплатно и посмотрите, как быстро и легко вы сможете рисовать диаграммы LAN и определять топологию сети в автоматическом режиме с использованием SNMP.
  • Хотели бы вы проверять и обнаруживать сети на объектах ваших клиентов и сохранять сетевые диаграммы для будущего анализа?
    10-Strike Network Diagram Screenshots Просканируйте сети вашего потенциального клиента с помощью ноутбука с помощью нашей программы построения диаграмм сети, создайте сетевые диаграммы и карты, сохраните или распечатайте их и решите, как лучше развернуть ваши устройства в сетевой инфраструктуре существующего потенциального клиента.

Преимущества использования программы

10-Strike Network Diagram was awarded by PC Magazine/RE in the BestSoft 2010 contest
  • Обнаружение и отображение топологии локальной сети
  • Обнаружение имен портов коммутатора и сетевых устройств через SNMP
  • Нарисовать схемы ЛВС для документов
  • Задокументируйте топологию сети
  • Экспорт сетевых диаграмм и карт в MS Visio

10-Strike Network Diagram была награждена журналом PC Magazine / RE в конкурсе «BestSoft 2010»!

Поддерживаемые операционные системы: Windows XP / Vista / 7/8.1/10; Сервер 2003/2008/2012/2016/2019

Наши клиенты

our clients

Как работает программа Network Diagramer

10-Strike Network Diagram предлагает два способа создания карты топологии сети.

Первый — автоматическое создание диаграмм. В соответствии с определенными пользователем диапазонами IP-адресов и методами сканирования приложение пытается найти устройства в сети. Доступные методы поиска включают проверку связи по ICMP, сканирование указанных портов TCP и попытки преобразовать IP-адрес в MAC (ARP).Приложение запускает несколько параллельных потоков для поиска устройств в указанном диапазоне. Сканирование диапазона из 1500 IP-адресов занимает не более 3-4 минут. Приложение также может обнаруживать устройства с активными агентами SNMP: коммутаторы, сетевые принтеры, маршрутизаторы и т. Д. Используя данные, полученные от коммутаторов по протоколу SNMP , приложение рисует графические соединения между обнаруженными сетевыми устройствами. При этом программа будет составлять красивую картинку из иконок и линий связи на карте в виде графиков.Подключения к коммутатору помечены именами портов этого коммутатора. 10-Strike Network Diagram использует оригинальный сложный алгоритм для распознавания типов устройств. Таким образом, приложение может распознавать сетевые и локальные принтеры, серверы, серверы баз данных, маршрутизаторы, коммутаторы и концентраторы.

Второй способ — ручное редактирование. Программа включает в себя библиотеку объектов, графических примитивов и линий. Путем несложных манипуляций нужные значки можно разместить на схеме, связать линиями соединения и пометить областями.Все операции интуитивно понятны и не занимают много времени.

Готовую схему сети можно сохранить как векторное (метафайл Windows) или растровое (JPEG, PNG, BMP) изображение или экспортировать в документ Microsoft Visio. Программа может распечатать диаграмму на бумаге с опциями для настройки качества печати, положения на странице и ориентации страницы.

Подробнее о нашем Network Diagrammer -> «10-Strike Network Diagram: Get the Picture of Your Network»

Подробнее о создании схемы топологии сети

Network Diagrammer Скриншоты

Пример схемы корпоративной сети:

Сканирование и обнаружение топологии сети через SNMP и создание сетевых диаграмм:

Начиная с версии 2.2, программа может создавать диаграммы глобальных сетей, используя трассировку маршрута. Программа позволяет использовать Google Maps в качестве фоновых изображений:

Больше скриншотов …

Скачать бесплатную 30-дневную пробную версию Ценообразование | Купить сейчас!

info Что еще? Если вы хотите контролировать хосты, размещенные на ваших сетевых диаграммах, попробуйте нашу программу сетевого сопоставления и мониторинга LANState Pro

.

network diagrammer, mapper, and monitor 10-страйк LANState Pro
Это программное обеспечение для отображения, мониторинга и администрирования сетей Windows.В дополнение к почти тем же функциям, что и 10-Strike Network Diagram , LANState Pro содержит монитор состояния сетевых устройств , который позволяет вам видеть состояние сетевых устройств на графической диаграмме в реальном времени. время и получать уведомления, когда ваши сетевые устройства выходят из строя или восстанавливаются. Оперативно реагируйте на сбои и минимизируйте расходы!

10-Strike Network Diagram имеет тот же движок векторной графики, но он не может отслеживать состояние ваших сетевых устройств, как 10-Strike LANState Pro .Это основное различие между этими двумя программами отображения сети, в то время как механизм обнаружения и рисования топологии сети одинаковый.

Мы рекомендуем вам попробовать обе программы и посмотреть, какая из них лучше подходит для ваших нужд. Для обоих приложений доступны 30-дневные пробные версии.

,Сетевая диаграмма

— узнайте, что такое сетевая диаграмма и многое другое

Сетевая диаграмма — это визуальное представление сетевой архитектуры. Он отображает структуру сети с помощью множества различных символов и линейных соединений. Это идеальный способ поделиться макетом сети, поскольку визуальное представление помогает пользователям понять, как элементы связаны.

Символы схемы сети

Сетевая диаграмма может включать сотни различных символов.Они могут варьироваться от ПК до сложной серверной стойки и облачной системы хранения. Символы могут быть специфичными для бренда, универсальными или комбинированными. Инструменты построения сетевых диаграмм в SmartDraw позволяют пользователям изменять существующие символы для создания пользовательской библиотеки символов для своей организации или ее клиентов.

Типы и использование сетевых схем

Сетевая диаграмма показывает, как один компьютер или система связаны с другими. Это особенно полезно при поиске проблем или при разработке новой системы.Часто корень проблемы легче обнаружить, наблюдая и анализируя, как подключены компьютеры и компоненты в системе.

Как нарисовать сетевую диаграмму

Существует много разных способов создания сетевой диаграммы. Хотя они могут быть созданы с помощью ручки и бумаги или белой доски, инструмент построения диаграмм, разработанный для этой цели, является гораздо более эффективным и действенным подходом.

Вы можете перетаскивать фигуры компонентов сети и соединять их линиями, чтобы легко проиллюстрировать соединения.Прочтите руководство по сетевой диаграмме SmartDraw.

Обратите внимание на эти советы:

  • Выберите сеть: Выберите сеть для иллюстрации. Схема может быть сосредоточена на персональном компьютере или на всей сети компании. После выбора фокуса установите ограничения на то, какие внешние подключения будут включены, чтобы диаграмма оставалась краткой.
  • Добавьте соответствующее оборудование: Начните с размещения всех задействованных компьютеров, серверов и других компонентов на странице.Используйте визуальные представления и добавьте названия компонентов для ясности.
  • Добавьте другие важные компоненты: Добавьте другие важные компоненты, такие как подключения к Интернету и брандмауэры. Еще раз, используйте визуальные представления и добавляйте текстовые описания по мере необходимости.
  • Наклейка: Обозначьте каждый элемент на странице, чтобы всем было легче понять, на что он смотрит. Либо пронумеруйте элементы и прикрепите легенду с описанием, чтобы диаграмма не загромождалась.
  • Нарисуйте соединительные линии: Используйте линии со стрелками направления, чтобы показать, как каждый компонент связан и связан с другим.

Примеры схем сети

Лучший способ понять сетевые диаграммы — это посмотреть на некоторые примеры сетевых диаграмм.

Щелкните любую из этих сетевых диаграмм, включенных в SmartDraw, и отредактируйте их:

Просмотрите всю коллекцию примеров и шаблонов сетевых диаграмм SmartDraw

,

Как создать сетевую диаграмму

В списке «Категории шаблонов» выберите категорию «Сетевая диаграмма». Все библиотеки в категории сетевых диаграмм появятся в центральном окне.

Базовая сетевая диаграмма

На основных сетевых схемах показаны основные части вашей сети и как эти части связаны. Эта статья описывает, как быстро создать базовую схему сети в Edraw Max. если ты были установлены Edraw, вы можете создать более подробную схему сети, используя шаблоны подробной сетевой схемы.Разница между основным и подробные шаблоны сетевых диаграмм заключается в том, что шаблон подробной сетевой диаграммы поставляется с большим количеством сетевых символов.

Создайте базовую схему сети

Откройте Edraw. Когда открывается Edraw, все, с чем вам нужно работать, это тот, который называется Категории шаблонов. (Советы: если у вас уже открыт Edraw, на главной странице Edraw , Наведите указатель на Создать, а затем нажмите Выбрать типы чертежей ….)

В шаблоне В списке категорий щелкните категорию Network Diagram .Все библиотеки в Категория схемы сети появится в центральном окне.

Create a Basic Network Diagram

Дважды щелкните шаблон с названием Basic Network Diagram .

Когда открывается библиотека фигур схем сети, большую часть места занимает пустая страница чертежа. Потому что важно выровнять формы при создании На диаграмме появится страница с линиями сетки.

Basic Network Diagram Symbols

Соедините фигуры сетевых диаграмм с помощью Smart Connector

В Edraw легко соединять фигуры схем сети.

На вкладке Home в группе Basic Tools щелкните инструмент Connector .

Создавать умный разъем нужно навести курсор на любую точку подключения форма. Точка подключения будет выделена красным.

Connect Network Diagram Shapes

Примеры сетевых диаграмм

Следующие изображения нарисованы с помощью программного обеспечения для построения схем сети Edraw.Вы можете найти больше примеров в галерее примеров. На следующих рисунках показаны некоторые основные сетевые схемы.

Схема домашней сети Дизайн сети Cisco Сеть Топологии

Создать подробную схему сети

Создание подробной сетевой диаграммы с Edraw — эффективный способ проектирования и задокументируйте компьютерную сеть, как показано на следующем рисунке.

Используя шаблоны подробной сетевой схемы и функции связи с данными, вы может создать диаграмму, которая показывает, как оборудование логически или физически подключены, добавьте исходные данные для идентификации каждой формы, а затем импортируйте и свяжите внешние данные к фигурам вашей сети.

Create a detailed network diagram

Ссылки:

Как нарисовать трехмерную схему сети

Диаграмма сети

Схема логистической сети

Шаблоны и примеры логических сетей

Шаблоны сетевых диаграмм

Схемы топологии сети, бесплатные примеры, шаблоны, загрузка программного обеспечения

.