Содержание

Network Maps. Краткий обзор софта для построения карт сети / Habr

0. Вводная..

..или немного оффтопаДанная статья родилась только потому, что крайне трудно найти сравнительные характеристики подобного программного обеспечения, а то и просто список, в одном месте. Приходится перелопатить кучу материала, чтобы прийти хоть к какому-то выводу.

В связи с этим я решил немного сэкономить время и силы тех, кого интересует данный вопрос, и собрал максимально возможное, читай осиленное мной, количество систем для network mapping’а в одном месте.

Часть систем, описанных в данной статье, были в свое время испробованы мной лично. Скорее всего, это были неактуальные на данный момент версии. Часть из нижеприведенного я вижу впервые, и информация по ним собиралась исключительно в рамках подготовки данной статьи.

В силу того, что трогал я системы давно, а часть из них не трогал вообще, у меня не осталось ни скриншотов, ни каких-либо примеров. Так что я освежил знания в гугле, вики, на youtube, сайтах разработчиков, там же натырил скриншотов, и в итоге получился вот такой вот обзор.

1. Теория

1.1. Зачем?

Чтобы ответить на вопрос «Зачем?» сначала нужно понять, что же такое «Карта сети». Карта сети – (чаще всего) логико-графико-схематическое представление взаимодействия сетевых устройств и их связи, которое описывает их наиболее значимые параметры и свойства. В наше время часто применяется в связке с мониторингом состояния устройств и системой оповещения. Так вот: затем, чтобы иметь представление о расположении узлов сети, их взаимодействии и связях между ними. В связке с мониторингом мы получаем рабочий инструмент для диагностики поведения и прогнозирования поведения сети.

1.2. L1, L2, L3

Они же Layer 1, Layer 2 и Layer 3 в соответствии с моделью OSI. L1 – физический уровень (провода и коммутация), L2 – уровень физической адресации (mac-адреса), L3 – уровень логической адресации (IP-адреса).

Строить карту L1 смысла, по сути, нет, она логически вытекает из той же L2, за исключением, пожалуй, медиаконвертеров. И то, сейчас существуют медиаконвертеры, которые так же можно отслеживать.

По логике – L2 строит карту сети, основываясь на mac-адресах узлов, L3 – на IP-адресах узлов.

1.3. Какие данные отображать

Тут зависит от решаемых задач и пожеланий. Мне, например, само собой хочется понимать, «жива» ли сама железка, на каком ее порту что «висит» и в каком состоянии порт – up или down. Это может L2. Да и вообще L2 мне кажется наиболее применимой в прикладном смысле топологией карты сети. Но, на вкус и цвет…

Скорость соединения на порту – неплохо, но не критично, если там находится конечное устройство – принтер\ПК. Хорошо бы иметь возможность посмотреть уровень загрузки процессора, количество свободной оперативной памяти и температуру на железке. Но это уже не так просто, тут нужно будет настраивать систему мониторинга, которая умеет читать SNMP и выводить и анализировать полученные данные. Об этом позднее.

По поводу L3 нашел вот такую статью.

1.4. Как?

Можно руками, можно в автоматическом режиме. Если руками – то долго и нужно учитывать человеческий фактор. Если автоматически – то нужно учесть, что все сетевые устройства должны быть «умными», уметь в SNMP и этот SNMP должен быть правильно настроен, чтобы система, которая будет собирать с них данные, смогла эти данные считать.

Вроде не сложно. Но есть подводные камни. Начиная с того, что не каждая система сможет считать с устройства все те данные, которые мы бы хотели видеть, или не все сетевые устройства могут эти данные отдать, и заканчивая тем, что не каждая система умеет сама строить карты сети в автоматическом режиме.

Процесс автоматического формирования карты примерно следующий:

  • система считывает данные с сетевого оборудования
  • на основе данных формирует для каждого порта маршрутизатора таблицу соответствия адресов на портах
  • сопоставляет адреса и имена устройств
  • строит связи порт-порт\устройство
  • отрисовывает все это в виде схемы, «интуитивно понятной» для пользователя

2. Практика

Итак, поговорим теперь о том, с помощью чего можно построить карту сети. Возьмем за отправную точку, что мы хотим, конечно же, максимально автоматизировать данный процесс. Ну, то есть Paint и MS Visio отпадают… хотяяяя… Нет, все-таки отпдают.

Существует специализированный софт, решающий задачу построения карты сети. Какие-то программные продукты могут только предоставить среду для «ручного» добавления картинок со свойствами, отрисовывания связей и запускают «мониторинг» в крайне урезанном виде (жива ли нода, или уже не отвечает). Другие же могут не просто самостоятельно отрисовать схему сети, но и считать кучу параметров с SNMP, оповещать пользователя по SMS в случае поломок, предоставить кучу информации по портам сетевой железки, и все это является лишь частью их функционала (та же NetXMS).

2.1. Продукты

Список далеко не полный, так как существует ну очень много подобного рода софта. Но это все, что выдает гугл по теме (в том числе и англоязычные сайты):

Open Source проекты:

LanTopoLog

Nagios

Icinga

NeDi

Pandora FMS

PRTG

NetXMS

Zabbix

The Dude

nMap

Платные проекты:

LanState

Total Network Monitor

Solarwinds Network Topology Mapper

UVexplorer

Auvik

AdRem NetCrunch

UserSide

2.2.1. Бесплатное ПО

2.2.1.1. LanTopoLog

Сайт

ПО разработки Юрия Волокитина. Интерфейс простой настолько, насколько это вообще возможно. Софтина поддерживает, скажем так, полуавтоматическое построение сети. Ей нужно «скормить» настройки всех маршрутизаторов (IP, SNMP credentials), далее все произойдет само, а именно будут построены связи между устройствами с указанием портов.

Есть платная и бесплатная версии продукта.

Видео-мануал

2.2.1.2. Nagios

Сайт

Open Source ПО, существует с 1999 года. Система разработана для мониторинга сети, то есть она умеет считывать данные через SNMP и автоматически строить карту сети, но так как это ее не основная функция, то делает она это весьма… странно… Для построения карт используется NagVis.

Видео-мануал

2.2.1.3. Icinga

Сайт

Icinga – это Open Source система, которая в свое время отпочковалась от Nagios. Система позволяет автоматически строить карты сети. Проблема лишь в том, что карты она строит при помощи аддона NagVis, который был разработан под Nagios, так что будем считать, что в качестве построения карты сетей эти две системы идентичны.

Видео- мануал

2.2.1.4. NeDi

Сайт

Умеет автоматически обнаруживать ноды в сети, и на основе этих данных строить карту сети. Интерфейс довольно простой, есть мониторинг состояния по SNMP.

Есть бесплатная и платная версии продукта.

Видео-мануал

2.2.1.5. Pandora FMS

Сайт

Умеет в автообнаружение, автопостроение сети, SNMP. Приятный интерфейс.

Есть бесплатная и платная версии продукта.

Видео-мануал

2.2.1.6. PRTG

Сайт

ПО не умеет в автоматическое построение карты сети, только перетаскивание картинок вручную. Но при этом умеет мониторить состояние устройств через SNMP. Интерфейс оставляет желать лучшего, на мой субъективный взгляд.

30 дней — полный функционал, потом — «бесплатная версия».

Видео-мануал

2.2.1.7. NetXMS

Сайт

NetMXS – это в первую очередь Open Source система мониторинга, построение карты сети – побочная функция. Но реализована она достаточно аккуратно. Автоматическое построение на основе автообнаружения, мониторинг нод по SNMP, умеет отслеживать состояние портов маршрутизаторов и другую статистику.

Видео-мануал

2.2.1.8. Zabbix

Сайт

Zabbix – это тоже Open Source система мониторинга, причем более гибкая и мощная, чем NetXMS, но карты сети он умеет строить только в ручном режиме, а вот мониторить может практически любые параметры маршрутизаторов, сбор которых только можно настроить.

Видео-мануал

2.2.1.9 The Dude

Сайт

В целом не сложная бесплатная утилитка, заточенная под работу с маршрутизаторами Mikrotic. Позволяет управлять устройствами, не выходя их программы. Так же может работать и с устройствами других вендоров, но об этом не заявлено официально, и списка поддерживаемых устройств я не нашел. На мой вкус интерфейс не самый приятный, но работать в нем можно.

Видео-мануал

2.2.1.10. nMap

Сайт

Основной функционал данного ПО — сканирование безопасности сети. Но на базе собранных данных система может построить и карту сети, правда, мониторить в привычном смысле она не может (насоклько я понял). Зато выводит исчерпывающую информацию на карту.

Видео-мануал

2.2.2. Платное ПО

2.2.2.1. LanState

Сайт

Платное ПО, позволяющее автоматически просканировать топологию сети и на базе обнаруженного оборудования построить карту сети. Позволяет мониторить состояние обнаруженных устройств только по up\down самой ноды.

Видео-мануал

2.2.2.2. Total Network Monitor

Сайт

Платное ПО, которое не умеет автоматически строить карту сети. Не умеет даже автоматически обнаруживать ноды. По-сути это тот же Visio, только ориентированный на сетевую топологию. Позволяет мониторить состояние обнаруженных устройств только по up\down самой ноды.

Черт! Я же писал выше, что от Paint и Visio мы отказываемся… Ладно, пусть будет.

Видео-мануал я не нашел, да он и не нужен… Программка так себе.

2.2.2.3. Solarwinds Network Topology Mapper

Сайт

Платное ПО, есть триал-период. Может автоматически просканировать сеть и самостоятельно составить карту по заданным параметрам. Интерфейс довольно простой и приятный.

Видео-мануал

2.2.2.4. UVexplorer

Сайт

Платное ПО, 15-тидневный триал. Умеет автообнаружение и автоматическое отрисовывание карты, мониторинг девайсов только по состоянию up/down, то есть через пинг устройства.

Видео-мануал

2.2.2.5. Auvik

Сайт

Довольно симпатичная платная программка, умеет в автообнаружение и мониторинг сетевых устройств.

Видео-мануал

2.2.2.6. AdRem NetCrunch

Сайт

Платная софтина с 14ти дневным триалом. Умеет в автоопределение и автопостроение сети. Интерфейс восторгов не вызвал. Умеет так же в SNMP мониторинг.

Видео-мануал

2.2.2.7. UserSide

Сайт

По-сути, это мощная ERP-система для провайдеров. Презентация с возможностями вот тут есть. Умеет мониторить все, что только можно и как только можно. Но это дорогой монстр, мощности которого для простого построения карты сети слишком велики… Но… Карты же он рисует…

Видео-мануал

3. Табличка сравнения

Как оказалось — придумать актуальные и важные параметры для сравнения систем и при этом уместить их в одну маленькую табличку — достаточно сложно. У меня родилось вот это:

*Параметр «User Friendly» является крайне субъективным, и я это понимаю. Но как еще описать «топорность и нечитаемость» я не придумал.

**«Мониторинг не только сети» подразумевает под собой работу системы как «системы мониторинга» в привычном понимании этого термина, то есть возможность считывать метрики с ОС, хостов виртуализации, получать данные от приложений в гостевых ОС и т.д.

4. Личное мнение

Из личного опыта — использовать ПО отдельно для мониторинга сети я не вижу смысла. Мне больше импонирует мысль использовать систему мониторинга всего и вся с возможностью построения карты сети. У Zabbix с этим дело обстоит… трудно. Nagios и Icinga — тоже. И только NetXSM порадовала в этом плане. Хотя, если заморочиться и сделать карту в Zabbix, то это выглядит даже более перспективным, нежели NetXMS. Есть еще Pandora FMS, PRTG, Solarwinds NTM, AdRem NetCrunch, и скорее всего куча еще чего, не вошедшего в данную статью, но я их видел только на картинках и в видео, так что ничего сказать о них не могу.

По поводу NetXMS была написана статья с небольшим обзором возможностей системы и небольшой how to.

P.S.:

Если я где-то ошибся, а я скорее всего ошибся, будьте добры, исправьте в комментариях, я подправлю статью, дабы тем, кому эта информация будет полезной, не пришлось все перепроверять на собственном опыте.

Спасибо.

habr.com

Algorius Net Viewer — Визуализация

Algorius Net Viewer — Визуализация



Редактор схемы компьютерной сети

Algorius Net Viewer — это редактор схемы компьютерной сети.
С его помощь можно отобразить сетевую инфраструктуру серверных, компьютерных классов, торговых и офисных центров, городских районов и других локаций наглядным образом.






Карта компьютерной сети

Схема компьютерной сети отображается на одной или нескольких картах.
Карты позволяют мгновенно увидеть всю сеть, ее состояние, получить быстрый доступ к администрированию и значительно упростить навигацию.







Построение карты сети

Мастер поможет найти устройства в сети и добавить их на карту.
Разнообразные способы обнаружения устройств (ARP, Ping, Netbios, TCP, UDP, SNMP, WMI) позволяют найти практически все устройства и получить информацию о них.







Коллекция устройств

Вместе с приложением поставляется коллекция из более 150 устройств в формате векторной графики (SVG).
Предусмотрено расширение коллекции своими устройствами в форматах SVG, JPG, PNG, GIF для создания более точных схем.







Описание устройств

Для устройств можно указать описание, изображение, контактную информацию, расположение, владельца и т.д.
Гиперссылки и email адреса распознаются автоматически. Это предоставляет быстрый доступ к нужной информации.







Соединение устройств

Устройства можно соединять друг с другом.
Соединения показываются на карте в виде линий.
Над линиями отображаются порты и интерфейсы, через которые происходит соединение.
Красно/зеленая индикация показывает их состояние.







Слои

Слои позволяют группировать объекты.
Каждая карта может содержать в себе уникальную иерархическую структуру слоёв.
Под каждым слоем отображается список его объектов.
Это упрощает редактирование карт и навигацию к устройствам.







Поддержка OpenStreetMap

На схемах в качестве подложки можно использовать географические карты OpenStreetMap.
Это позволяет позиционировать устройства с привязкой к местности и наглядно видеть их географическое расположение.







Экспорт / импорт Visio

Algorius Net Viewer позволяет экспортировать карту компьютерной сети в документ Visio, а также на основе документа Visio создать карту компьютерной сети.
Это удобно для создания презентаций и для обмена картами с третьими лицами.













© ООО «Алгориус Софтвер», 2010-2019


www.algorius.com

бесплатный генератор тополгии Active Directory и Exchange. – Сибирский ТАМ

У любого ситемного администратора время от времени возникает желание иметь карту своей сети. Разумные ИТ-менеджеры в первую очередь требуют создать документацию для ввереного сетевого и серверного хозяйства. Это неудивительно, ведь документация – вещь крайне полезная и ценная. Удивительно другое – насколько редко можно встретить актуальную и понятную документацию на серверное и сетевое хозяйство. Сегодня мы поговорим о том как легко начать путь документирования. Более того, исползуя советы из этой статьи вы не только сможете порзаить своего начальника красивыми картинками, но еще и получите средство диагностики для вашей инфраструктуры Active Directory и Exchange.

Active Directory Topology Diagrammer (ADTD), в два клика создает:

  • Карту активного леса Active Directory со всеми контроллерами домена, с указанием ролей FSMO и GC
  • Топологию сайтов и текущие состояние линков репликации, что по идее сильно похоже на карту сети
  • Диаграмму серверов, групп маршрутизации и администрирования для Exchange 2003
  • Топологию маршрутизации и сервера для Exchange 2007
  • Диаграмму организационных подразделений (Organizational Unit, OU)

Когда я как менеджер Premier Support прихожу к своему заказчику в первый раз, первым делом мы создаем карту инфраструктуры AD и Exchange с помощью бесплатной утилиты Active Directory Topology Diagrammer (ADTD). Эта утилита была разработана внутри команды премьер поддержки достаточно давно. Долгое время была доступна только для заказчиков Premier Support, а в прошлом году, после проведения всех необходимых тестовых процедур, утилита была опубликована в разделе загрузки для всех желающих. В море других утилит дигараммер до сих пор не всем заметен, хотя грамотные люди его используют и рекомендуют на форумах. Немного пройдясь поисковыми машинами по русскому интернету, я обнаружил только одно хорошее описание диаграммера на сайте Exchangerus.ru.

Установка и первые шаги в Active Directory Topology Diagrammer

Для работы с ADTD нам понадобится компьютер с установленными .Net framework 2.0 и Visio 2003 или 2007. Требования к правам пользователя невелики – компьютер, где вы будуте создавать карты, должен быть членом домена. Также, вам потребуется логин и пароль пользователя из домена. Начинте скачивать (ADTD) прямо сейчас, а пока идет загрузка и установка, дочитывайте этот пост.

На картинке слева изображено главное окно диаграммера. Настройка программы предельно проста – укажите в поле Server имя сервера глобального каталога AD, выберете необходимые вам диаграммы и их свойства, далее нажмите Discover. Подождите несколько десятков секунд, пока происходит чтение информации. Для некоторых операций, например, подсчета количества почтовых ящиков, необходимо подключение к соответствующим серверам. Так что процедура сбора информации может занять больше времени, и потребуется расширенный сетевой доступ.

После того как программа собрала всю необходимую информацию, активируется кнопка Draw. Нажимайте ее, и у вас откроется новое окно MS Visio. В этом окне начнут появляться сервера, сайты, связи, вообщем все то, что вы желаете видеть. Не пугайтесь страшного нагромождения объектов. Сначала происходит наполнение данными, а затем ADTD производит перегруппировку всех объектов. Первый раз достаточно интересно наблюдать за тем, как это происходит. В дальнейшем, всегда сворачивайте(минимизируйте) окно VISIO для того, чтобы значительно ускорить процесс построения диаграмм. Потому что именно вывод на экран обновленной после каждого изменения картинки, наиболее тормозит процесс построения карты. Сам расчет оптимального дизайна проивзодится достаточно быстро. Что-же, карты готовы, давайте обсудим, что мы можем из них получить.

Карта доменов Active Directory

Карта доменов содержит список всех доменов в лесу плюс все внешние доверительные домены. На рисунке справа, большой вариант которого открывается в отдельном окне, вы видите пример карты доменов леса Active Directory. Что важного мы можем вынести из это диаграммы?

  1. Наглядно увидеть весь лес целиком с указанем функиональных уровней леса и домена, а также версию схемы AD
  2. Распределение ролей FSMO для леса и каждого из доменов.
  3. Узнать данные всех контроллеров домена: название, версия ОС и Service Pack, флаг глобального каталога (отражается в виде глобуса)
  4. Общее количество пользователей и контроллеров домена в каждом из доменов

Согласитесь, такие знания об инфраструктуре Active Directory часто просто необходимы при дигностике проблем и планировании новых внедрений. Особенно хорошо, что всю существуенную информацию о доменах можно увидеть на одном листе. Просто превосходная диаграмма, я считаю!

Топология сайтов и текущие свзяи для репликации Active Directory

Диграмма сайтов — отличный метод получить карту локальной сети. Конечно в том случае, если создатели инфраструктуры AD действительно внимательно подошли к вопросу планирования и внедрения. Что мы можем обнаружить на данной диаграме?

  1. Объекты для всех сайтов Active Directory, которые связаны друг с другом так, как это задано в оснастке AD Sites’n’Services
  2. Каждый сайт содержит свои подсети в виде значков с описанием
  3. Важные свойства каждого из сайт-линков: интервал репликации и стоимость.
  4. Реальные репликационные связи на момент создания диаграммы.

Понятно, что если первая диграмма в основном используется только для того, чтобы войти в курс дела, то диграмма сайтов – это наглядный инструмент для дигностики проблем с репликацией. Именно на этой диагрмме можно легко обнаружить такие распространеные ошибки как

  • Пустые сайты, т.е. без контроллеров домена.
  • Сайты без под-сетей
  • Связи больше чем с двумя сайтами одновременно

Карта почтовой организации Exchange

Карта серверов Exchange – это очень мощный инструмент. Особенно полезен для инфраструктуры Exchange 2003, где у нас есть отдельно административные группы и группы маршрутизации. Содержание:

  • Все сервера и кластерные группы Exchange организации, включая роли: backend/frontend.
  • Группы маршрутизации и их связь между собой
  • Для связей групп маршрутизаций(E2K3) и сайтов AD (E2K7) отражаются все важные параметры
  • Версия сервера Exchange и версия пакета обновления.
  • Плюс можно включить подсчет количества почтовых ящиков на каждом из серверов.

Именно эта карта покажет вам каким образом ходит почта внутри организации, как и откуда она может попадать в интернет и т.п.

Чем мне еще нравится ADTD, так это тем, что он уже поддерживает Exchange 2007 со всеми ролям, т.е. можно увидеть и кластера и пограничный сервер – вообщем прекрасная карта, смотрите сами.

Понятная и опрятная диграмма ADTD – залог стабильности AD и Exchange

 Этот пост имеет тэг ит-менеджеру. Казалось бы, зачем какая-то технологическая карта может быть реально полезна начальнику отдела или директору ИТ? Ответов здесь два. Во-первых, наличие документации само по себе очень правильное дело. Частенько инженеры ссылаются на нехватку времени, как причину отсутсвия документации. Теперь вы знаете, что для AD и Exchange минимальная документация делается в пару кликов мышки. Ее лучше сделать прямо сегодня! Ведь если завтра ваш администратор уйдет в отпуск, и случится большой сбой, то будет понятно хоть что восстанавливать тем инженерам, кого вы сможете обнаружить под рукой.

Во-вторых, ADTD позволяет провести наглядный и быстрый аудит состояния инфраструктуры AD и Exchange. Это особенно легко сделать для гегорафически-распределенных организаций. Посмотрите на приведенную выше диграмму сайтов, очевидно и без глубоких знаний Active Directory, что в такой инфраструктуре что-то совсем-совсем плохо, а в случае проблем понять что и от чего действительно завсит невозможно. Пример из реальной жизни российской компании, где после приведения в порядок топологии сайтов нашими инженерами, диграмма приобрела следующий красивый и предсказуемый вид звезды.

У вас до сих пор нет карты своей сети? Прямо сегодня дайте задание инженерам скачать Active Directory Topology Diagrammer (ADTD), и посмотрите сами, на сколько разумно и эстетично выглядят диграммы вашей инфраструктуры!

blogs.technet.microsoft.com

Как создавать понятные логические (L3) схемы сети / Habr

Cамая большая проблема, с которой я сталкиваюсь при работе с сетями предприятий — это отсутствие чётких и понятных логических схем сети. В большинстве случаев я сталкиваюсь с ситуациями, когда заказчик не может предоставить никаких логических схем или диаграмм. Сетевые диаграммы (далее L3-схемы) являются чрезвычайно важными при решении проблем, либо планировании изменений в сети предприятия. Логические схемы во многих случаях оказываются более ценными, чем схемы физических соединений. Иногда мне встречаются «логически-физически-гибридные» схемы, которые практически бесполезны. Если вы не знаете логическую топологию вашей сети, вы слепы. Как правило, умение изображать логическую схему сети не является общим навыком. Именно по этой причине я пишу эту статью про создание чётких и понятных логических схем сети.

Какая информация должна быть представлена на L3-схемах?

Для того, чтобы создать схему сети, вы должны иметь точное представление о том, какая информация должна присутствовать и на каких именно схемах. В противном случае вы станете смешивать информацию и в итоге получится очередная бесполезная «гибридная» схема. Хорошие L3-схемы содержат следующую информацию:

  • подсети
    • VLAN ID (все)
    • названия VLAN’ов
    • сетевые адреса и маски (префиксы)

  • L3-устройства
    • маршрутизаторы, межсетевые экраны (далее МСЭ) и VPN-шлюзы (как минимум)
    • наиболее значимые серверы (например, DNS и пр.)
    • ip-адреса этих серверов
    • логические интерфейсы

  • информацию протоколов маршрутизации

Какой информации НЕ должно быть на L3-схемах?

Перечисленной ниже информации не должно быть на сетевых схемах, т.к. она относится к другим уровням [модели OSI, прим. пер.] и, соответственно, должна быть отражена на других схемах:

  • вся информация L2 и L1 (в общем случае)
  • L2-коммутаторы (может быть представлен только интерфейс управления)
  • физические соединения между устройствами

Используемые обозначения

Как правило, на логических схемах используются логические символы. Большинство из них не требуют пояснений, но т.к. я уже видел ошибки их применения, то позволю себе остановиться и привести несколько примеров:

  • Подсеть, представленная как трубка или линия:
  • VRF или другая не известная точно зона представляется в виде облака:

Какая информация необходима для создания L3-схемы?

Для того, чтобы создать логическую схему сети, понадобится следующая информация:

  • Схема L2 (или L1) — представление физических соединений между устройствами L3 и коммутаторами
  • Конфигурации устройств L3 — текстовые файлы либо доступ к GUI, и т.д.
  • Конфигурации устройств L2 — текстовые файлы либо доступ к GUI, и т.д.
Пример

В данном примере мы будем использовать простую сеть. В ней будут присутствовать коммутаторы Cisco и МСЭ Juniper Netscreen. Нам предоставлена схема L2, также как и конфигурационные файлы большинства представленных устройств. Конфигурационные файлы пограничных маршрутизаторов ISP не предоставлены, т.к. в реальной жизни такую информацию ISP не передаёт. Ниже представлена L2-топология сети:

А здесь представлены файлы конфигурации устройств. Оставлена только необходимая информация:

asw1

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.11 255.255.255.128
!
ip default-gateway 192.168.10.1

asw2

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.12 255.255.255.128
!
ip default-gateway 192.168.10.1

asw3

!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.13 255.255.255.128
!
ip default-gateway 192.168.10.1

csw1

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.29 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.2 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.130 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.2 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.130 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.2 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17

csw2

!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.30 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.3 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.131 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.3 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.131 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.3 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17

fw1

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.2
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.18
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12

fw2

set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.3
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.19
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12

outsw1

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr1
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.50 255.255.255.240
!
ip default-gateway 10.0.0.49

outsw2

!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr2
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.51 255.255.255.240
!
ip default-gateway 10.0.0.49

Сбор информации и её визуализация

Хорошо. Теперь, когда мы имеем всю необходимую информацию, можно приступать к визуализации.

Процесс отображения шаг за шагом

  1. Сбор информации:
    1. Для начала откроем файл конфигурации (в данном случае ASW1).
    2. Возьмём оттуда каждый ip-адрес из разделов интерфейсов. В данном случае есть только один адрес (192.168.10.11) с маской 255.255.255.128. Имя интерфейса — vlan250, и имя vlan 250 — In-mgmt.
    3. Возьмём все статические маршруты из конгфигурации. В данном случае есть только один (ip default-gateway), и он указывает на 192.168.10.1.

  2. Отображение:
    1. Теперь давайте отобразим информацию, которую мы собрали. Во-первых, нарисуем устройство ASW1. ASW1 является коммутатором, поэтому используем символ коммутатора.
    2. Нарисуем подсеть (трубку). Назначим ей имя In-mgmt, VLAN-ID 250 и адрес 192.168.10.0/25.
    3. Соединим ASW1 и подсеть.
    4. Вставляем текстовое поле между символами ASW1 и подсети. Отобразим в нём имя логического интерфейса и ip-адрес. В данном случае имя интерфейса будет vlan250, и последний октет ip-адреса — .11 (это является общей практикой — отображать только последний октет ip-адреса, т.к. ip-адрес сети уже присутствует на схеме).
    5. Также в сети In-mgmt есть другое устройство. Или, как минимум, должно быть. Нам ещё неизвестно имя этого устройства, но его IP-адрес 192.168.10.1. Мы узнали это потому, что ASW1 указывает на этот адрес как на шлюз по-умолчанию. Поэтому давайте отобразим это устройство на схеме и дадим ему временное имя «??». Также добавим его адрес на схему — .1 (кстати, я всегда выделяю неточную/неизвестную информацию красным цветом, чтобы глядя на схему можно было сразу понять, что на ней требует уточнения).

На этом этапе мы получаем схему, подобную этой:

Повторите этот процесс шаг за шагом для каждого сетевого устройства. Соберите всю информацию, относящуюся к IP, и отобразите на этой же схеме: каждый ip-адрес, каждый интерфейс и каждый статический маршрут. В процессе ваша схема станет очень точной. Убедитесь, что устройства, которые упомянуты, но пока неизвестны, отображены на схеме. Точно так же, как мы делали ранее с адресом 192.168.10.1. Как только вы выполните всё перечисленное для всех известных сетевых устройств, можно начать выяснение неизвестной информации. Вы можете использовать для этого таблицы MAC и ARP (интересно, стоит ли писать следующий пост, рассказывающий подробно об этом этапе?).

В конечном счёте мы будем иметь схему наподобие этой:

Заключение

Нарисовать логическую схему сети можно очень просто, если вы обладаете соответствующими знаниями. Это продолжительный процесс, выполняемый вручную, но это отнюдь не волшебство. Как только у вас есть L3-схема сети, достаточно нетрудно поддерживать её в актуальном состоянии. Получаемые преимущества стоят приложенных усилий:

  • вы можете планировать изменения быстро и точно;
  • решение проблем занимает гораздо меньше времени, чем до этого. Представим, что кому-то нужно решить проблему недоступности сервиса для 192.168.0.200 до 192.168.1.200. После просмотра L3-схемы можно с уверенностью сказать, что МСЭ не является причиной данной проблемы.
  • Вы можете легко соблюдать корректность правил МСЭ. Я видел ситуации, когда МСЭ содержали правила для трафика, который никогда бы не прошёл через этот МСЭ. Этот пример отлично показывает, что логическая топология сети неизвестна.
  • Обычно как только L3-схема сети создана, вы сразу заметите, какие участки сети не имеют избыточности и т.д. Другими словами, топология L3 (а также избыточность) является такой же важной как избыточность на физическом уровне.

habr.com

Сканируем IP-сети с любым количеством объектов и строим карту сети — Nmap

Доброго времени суток, дорогие друзья, знакомые, читатели и прочие личности.

В жизни IT-шника бывает такое, что необходимо, по каким-либо соображениям, просканировать сеть, её порты, сервисы и службы, а так же узнать их состояние, назначение и уровень безопасности, попутно и, в частности, составить карту сети и её топологию.

Причем таковое может быть необходимо не только какому-нибудь там системному администратору, но и простому пользователю, а и сканирование можно проводить не только в рамках локальной сети, но и вне неё (например, посмотреть через какие хоп’ы идет путь до того же google.ru).

В общем, давайте поговорим о такой достаточно известной программе, как и Nmap.
Поехали.

Установка и использование Nmap для исследования сетей, сканирования портов и тп.

Дабы не изобретать велосипед и не рассказывать всё своими словами, в этот раз, я хотел бы просто поделится краткой выдержкой из руководства с сайта разработчика:

Nmap (“Network Mapper”) — это утилита с открытым исходным кодом для исследования сети и проверки безопасности. Она была разработана для быстрого сканирования больших сетей, хотя прекрасно справляется и с единичными целями.

Nmap использует сырые IP пакеты оригинальными способами, чтобы определить какие хосты доступны в сети, какие службы (название приложения и версию) они предлагают, какие операционные системы (и версии ОС) они используют, какие типы пакетных фильтров/брандмауэров используются и еще дюжины других характеристик.

В тот время как Nmap обычно используется для проверки безопасности, многие сетевые и системные администраторы находят ее полезной для обычных задач, таких как контролирование структуры сети, управление расписаниями запуска служб и учет времени работы хоста или службы.

В «двух» словах как-то вот так, что, думаю, прекрасно даёт общее понимание о назначении программы и задачах ею решаемых. Посему давайте перейдем к загрузке и установке.

Скачать можно с этой страницы, а конкретней с такового вот «репозитория». Если совсем лень разбираться, то такая прямая ссылка для владельцев Windows. Установка в принципе проста и я на ней останавливаться не буду.

Единственное, что на одном из этапов Вы можете, либо оставить (либо, как ни странно, снять) галочки, отвечающие за запуск вспомогательных служб. Что касается использования, то ничего сложно нет. Запускаем программу:

Где в окне «Цель» вводим домен (например тот же «google.ru») или IP-адрес и жмём в кнопочку «Сканирование», после чего ожидаем процесса сканирования и видим результаты:

Переключаясь по вкладкам можно увидеть много полезной информации, вроде той же топологии сети, различные порты и сервисы, детали хоста и прочее прочее:

В принципе на сим базовую работу с программой можно считать освоенной. В Nmap есть еще много всего вкусного и интересного, в том числе и различные варианты сканирования:

С остальным Вы можете разобраться самостоятельно, а в помощь Вам подробная инструкция на русском языке, что живет по этой самой ссылке.

На сим, пожалуй, всё. Можно переходить к послесловию.

Послесловие

Ну вот как-то так, если говорить совсем кратко.

Как и всегда, если есть какие-то мысли, дополнения, вопросы и всё такое прочее, то добро пожаловать в комментарии к этой записи.

Мы в соц.сетях: ВКFacebookTwitter Telegram

sonikelf.ru

Автоматическое создание схемы сети бесплатно LanTopoLog


LanTopoLog 2 version 2.43


Лицензия:    Условно-бесплатная

Функция распознавания топологии сети работает без ограничений и в незарегистрированной

версии, то есть LanTopoLog предоставляет бесплатный инструмент для создания схемы сети

Автор:       Юрий Волокитин 

Системные требования:     Windows Vista/2008/7/8/2012/10/2016

Возможности LanTopoLog


— автоматическое построение физической топологии локальной сети

  на основе данных, собранных с коммутаторов по протоколу SNMP

— отображение схемы сети в двух-панельном браузерe

— показывает все устройства на всех портах коммутаторов, их имена и адреса IP

— настраиваемое контекстное меню для иконок компьютеров и коммутаторов

— отображение номеров VLAN, портов LACP

— мониторинг состояния Spanning Tree и оповещение об изменениях в топологии STP

— ping мониторинг всех хостов сети

— отображение даты и времени последнего ответа на ping каждого компьютера

— добавление в схему любых данных, привязанных к mac адресу в

  в импортируемом файле

— публикация схемы сети на web сервере

— поиск в базе данных LanTopoLog в том числе и через web браузер

— автоматическое добавление компьютеров в схему сети по мере их

  подключения к сети с записью в журнале об обнаружения нового

  mac адреса и с оповещением администраторов

— индикация состояния тревоги и оповещение администраторов

  с помощью e-mail

— инвентаризация компьютеров в сети предприятия средствами WMI

— экспорт списка коммутаторов и таблицы соединений коммутаторов в csv файл

— экспорт списка компьютеров в csv файл

— отображение скорости соединения на всех портах коммутаторов

— мониторинг сетевого трафика, что позволяет узнать источник

  трафика с точностью до порта коммутатора

— мониторинг ошибочных и потерянных пакетов (ifInErrors, ifInDiscards)

— оповещение администраторов о превышении заданных порогов трафика

— простой интерфейс

— программа не производит никаких записей в системные области (реестр,

  системные папки) и является портативной

— программа безопасна и не имеет функций передачи данных через интернет

Вопросы и пожелания по LanTopoLog шлите   [email protected]

Также можете воспользоваться Формой обратной связи

Copyright © 2007-2019 by Yuriy Volokitin.  All Rights Reserved.


www.lantopolog.com

Десять программ для составления схемы сети на любой бюджет

CADE (бесплатная)

Векторный 2D-редактор CADE для Windows разработан компанией, специализирующейся на работе с САПР. Программа позволяет с легкостью составить подробную схему сети. Одна из самых полезных, на мой взгляд, функций — возможность подписать IP-адрес, серийный номер и название фирмы-производителя для каждого устройства в сети. CADE включает все необходимые для составления схемы шаблоны и распространяется абсолютно бесплатно.



Concept Draw Pro

Concept Draw Pro — один из наиболее мощных бизнес-инструментов для составления диаграмм, причем не только сетевых. На освоение программы требуется минимум времени — все операции осуществляются простым перетаскиванием. В состав Concept Draw Pro входит полный набор сетевых символов, а все аспекты диаграммы можно персонализировать. Стоимость приложения — 249 долларов.

Dia (бесплатная)

Dia — открытое ПО для составления диаграмм, главным недостатком которого является устаревший интерфейс и примитивный набор символов. Зато программу очень легко использовать, не отвлекаясь ни на какие посторонние задачи. Dia распространяется бесплатно и работает практически во всех настольных дистрибутивах Linux.

Diagram Designer (бесплатная)

Diagram Designer — еще одна бесплатная утилита с устаревшим интерфейсом, зато очень простая в обращении, благодаря чему наверняка придется по вкусу многим пользователям. В отличие от Dia, программа предлагает куда более широкий выбор символов и значков. Единственное, что мне не понравилось в Diagram Designer, — это необходимость рисовать соединения между компьютерами вручную, потому что для этого в программе используется произвольная форма. За исключением этого небольшого недостатка, DD — вполне достойное решение.

eDraw Max

eDraw Max — один из лучших инструментов в этом списке, за исключением, разумеется, Visio. Программа проста в освоении, обладает удобным, и притом наиболее современным пользовательским интерфейсом из всех перечисленных вариантов. eDraw Max представляет собой полофункциональное средство для составления бизнес-диаграмм любого назначения, а не только сетевых схем. Стоимость решения составляет 99,95 долларов за одну лицензию, причем чем больше лицензий, тем дешевле стоит каждая из них.

GoVisual Diagram Editor (бесплатная)

Бывают на редкость неудачные программы, и GoVisual Diagram Editor — одна из них. Это сложный в обращении инструмент, обеспечивающий далеко не удовлетворительные результаты. Хотя с его помощью все-таки можно составить схему сети, она будет не особенно удобна для чтения, поскольку в GoVisual Diagram Editor отсутствуют некоторые полезные функции — в частности, значки сетевых устройств. Но если кому-то нужна бесплатная программа для составления диаграмм любого назначения, GoVisual — как раз подходящий вариант, потому что распространяется даром.

LanFlow

LanFlow я бы включил в число лучших. Программа обладает превосходным интерфейсом, предлагает богатый выбор сетевых объектов и позволяет с легкостью создавать схемы локальной, телекоммуникационной, внешней сети, а также диаграммы компьютеров. В LanFlow даже предусмотрено два разных шаблона сетевых диаграмм: 3D-схема и черно-белая. Чтобы создать схему, достаточно выбрать шаблон и перетащить на него подходящие объекты, которые можно группировать, удалять и так далее. Однопользовательская лицензия на программу стоит 89 долларов, так что LanFlow по праву может называться одной из лучших бюджетных альтернатив Visio.

NetProbe

Хотя NetProbe можно использовать и для составления схем, основное назначение программы — это мониторинг сетевых устройств в режиме реального времени. Но главное достоинство NetProbe как средства для построения диаграмм заключается в том, что сетевые устройства можно добавлять на схему по мере необходимости, причем даже заранее. Делать это вручную не обязательно — встроенный компонент NetProbe автоматически сканирует сеть и составляет список всех доступных в сети устройств. Версия Standard бесплатна, но может отслеживать всего восемь хостов. Версия Pro стоит всего 40 долларов и рассчитана на 20 хостов, а версия Enterprise, позволяющая вести мониторинг 400 хостов, предлагается по цене 295 долларов.

Network Notepad (бесплатная)

Network Notepad (буквально «сетевой блокнот») представляет собой именно то, что следует из названия — блокнот для составления сетевых диаграмм. Но несмотря на кажущуюся простоту, программа обладает богатыми возможностями, включая интерактивные функции (Telnet, просмотр сети, пингование и т. д.). Network Notepad имеет простой интерфейс с поддержкой перетаскивания и умеет автоматически обнаруживать устройства Cisco. Распространяется программа бесплатно.

Microsoft Visio

Visio — это, конечно, фактический стандарт на рынке приложений для составления диаграмм в Windows. Программа позволяет с легкостью создавать красивые схемы сети и обеспечивать к ним общий доступ через веб-браузер. Visio включает богатый набор шаблонов, в том числе для центров обработки данных, служб помощи, сетевых стоек; для консолидации офиса, планирования сети в масштабах предприятия, ЦОД или домашнего офиса; для составления дерева неисправностей, плана отопления, вентиляции, кондиционирования и т. п. Visio — лучшее решение для составления сетевых схем, а потому и стоит оно недешево: 249,99 долларов за версию Standard, 559,99 за Professional и 999,99 за Premium 2010. Подробнее о возможностях версий можно прочитать на официальной странице Visio.

Автор: Selena Frye
Перевод SVET



Оцените статью: Голосов 16

www.winblog.ru