Содержание

ppp1.ru… Just a moment…. Реформал.

Рейтинг:

Адрес:

http://ppp1.ru

Безопасность данных:

Не определена

Степень доверия:

Не определена

Безопасность для детей:

Не определена

О сайте:

Анализ данных ppp1.ru показал, что у этого домена отсутствует рейтинг Alexa и посещаемость данного сайта неизвестна. Лидирующую позицию по доле трафика занимает Россия (83,2%), а владельцем домена является Private Person.

Заголовок:

Just a moment…

Мета-описание:

Услуга по регистрации доменного имени PPP1.RU временно не предоставляется.

Рейтинг Alexa

Нет данных

Посетителей в день

Нет данных

Просмотров в день

Нет данных

Статус:

Оффлайн

Дата последней проверки:

Настраиваем два одновременных VPN соединения в Linux (для доступа в инет и для доступа к локальным ресурсам ISP)

Подключившись к новому провайдеру, предоставляющему доступ в сеть по впн пришлось столкнуться с кучей манов и факов на тему поднятия двух одновременно работающих впн-соединений в линях. Поднимал в убунте 9.10 и решил как-то скомпилировать инфу в один надеюсь понятный фак.

Данный FAQ будет полезен тем, кто хочет настроить два одновременных впн-соединения для локальной и внешней сети.


Для начала нужно скачать пакет, который обеспечит поддержку нужного нам протокола соединения, для этого введём в терминале:

sudo apt-get install pptp-linux

После того как пакет установлен, идём писать конфиг соединения в папку /etc/ppp/peers, для этого нам понадобятся права админа (если их уже нет), для удобства напишу стандартный терминальный вход с нужными правами в терминальном редакторе nano в создаваемый файл конфигурации соединения:

sudo nano /etc/ppp/peers/connection_name1

Где connection_name1 — имя создаваемого подключения (можете назвать как вам удобно).
Далее вводим в окно редактирования данные соединения:

pty «pptp vpn.isp.ru —nolaunchpppd»
user «ваш логин»
password «ваш пароль»
unit 0
nodeflate
nobsdcomp
noauth
replacedefaultroute
defaultroute
persist
maxfail 0

Где vpn.isp.ru — впн-сервер для доступа в интернет вашего провайдера, а логин и пароль для доступа к интернету.
Жмём ctrl+x, потом подтверждаем сохранение клавишей Y.
Итак, первый конфиг готов, далее пишем второй для локального соединения:

sudo nano /etc/ppp/peers/connection_name2

Где опять же имя соединения можете придумать своё=)
Туда пишем:

pty «pptp vpnx.isp.ru —nolaunchpppd»
user «ваш логин»
password «ваш пароль»
unit 1
lock
nodeflate
nobsdcomp
noauth
persist
maxfail 0

Где vpnx.isp.ru — впн-сервер для доступа в локальную среду вашего провайдера, а логин и пароль также для локального доступа.
Сохраняем всё это дело ctrl+x, затем Y.

Конфиги готовы.
Теперь настроим автозапуск и маршрутизацию на локалку.
Для этого редактируем /etc/network/interfaces:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp
‘up route add -net 10.0.0.0 netmask 255.0.0.0 gw 10.66.6.1

auto connection_name1

iface connection_name1 inet ppp
provider connection_name1

auto connection_name2
iface connection_name2 inet ppp
provider connection_name2

Тут вы можете внести маршруты для доступа к ресурсам непосредственно через имеющееся соединение (без впн). Пример такого маршрута я закомментировал, поэтому при добавлении маршрута Вам придётся убрать символ » » из данного конфига.
Где на месте 10.66.6.1 должен быть Ваш локальный шлюз.
Далее идём писать скрипты маршрутов для connection_name2.
Нам нужно создать /etc/ppp/ip-up.d/route
Пишем в терминале:

sudo nano /etc/ppp/ip-up.d/route

Пишем в открывшемся редакторе маршруты вида:

#!/bin/sh
ip route add 10.200.0.0/16 dev ppp1

Где ppp1 — ссылка на соединение connection_name2
Жмём

ctrl+x, потом подтверждаем сохранение клавишей Y.

Затем делаем этот скрипт исполняемым, для этого пишем в терминале:

sudo chmod +x /etc/ppp/ip-up.d/route

Далее нужно создать скрипт на удаление маршрутов.
Пишем в терминале:

sudo nano /etc/ppp/ip-down.d/route

Пишем в открывшемся редакторе:

#!/bin/sh
ip route add default gw dev eth0

Жмём ctrl+x, потом подтверждаем сохранение клавишей Y.

Затем делаем этот скрипт исполняемым, для этого пишем в терминале:

sudo chmod +x /etc/ppp/ip-down.d/route

Всё, теперь пишем в терминале команду перезапуска сети:

sudo /etc/init.d/networking restart

И теперь инет настроен, маршруты прописаны. Конечная цель достигнута.
Надеюсь ничего не забыл.

Cisco Router 1941 настройка работы интернета в Билайн по l2tp

Многое поменялось. Теперь не нуно настраивать l2tp. Смотри подробнее здесь

Исправления и замечания приветствуются.

L2TP SERVERS (BRAS)

85.21.0.241 — tp.internet.beeline.ru — работает как мне нужно
85.21.0.254 — работает как мне нужно

85.21.0.109 — tp.corbina.net — как минимум не предоставляет маршруты после авторизации. (руками не пробовал прописывать)
85.21.0.65 — vpn.corbina.ru — как минимум не предоставляет маршруты после авторизации. (руками не пробовал прописывать)

Базовая настройка роутера:

IOS: c1900-universalk9-mz.SPA.152-4.M2.bin
Последние версии ios крашились при попытке настроить NAT.

GigabitEthernet0/0 — внешняя сеть
GigabitEthernet0/1 — внутренняя сеть

cisco-router-1941> en
cisco-router-1941# conf t

– To enable the Domain Name System (DNS) server on a router

cisco-router-1941(config)# ip dns server 
cisco-router-1941(config)# ip name-server 85.21.192.3
cisco-router-1941(config)# ip name-server 213.234.192.8
cisco-router-1941(config)# ip name-server 85.21.192.5
cisco-router-1941(config)# ntp server ntp.corbina.net
cisco-router-1941(config)# ntp server ru.pool.ntp.org

– удаляю прописанные ранее dns сервер и шлюз по умолчанию

cisco-router-1941(config)# no ip name-server 192.168.1.1
cisco-router-1941(config)# no ip default-gateway 192.168.1.1

Предварительная настройка интерфейсов

– GigabitEthernet0/0

cisco-router-1941(config)# interface GigabitEthernet0/0
cisco-router-1941(config)# ip address dhcp
cisco-router-1941(config)# load-interval 30
cisco-router-1941(config)# description ISP-External-Local
cisco-router-1941(config)# no shutdown
cisco-router-1941(config)# exit

– GigabitEthernet0/1

cisco-router-1941(config)# interface GigabitEthernet0/1
cisco-router-1941(config)# ip address 192.168.1.1 255.255.255.0
cisco-router-1941(config)# 
description Internal-NetWork
cisco-router-1941(config)# no shutdown
cisco-router-1941(config-if)# exit
cisco-router-1941(config)# exit

– проверка получения ip адреса от провайдера

cisco-router-1941# show dhcp lease
Temp IP addr: 10.111.0.8  for peer on Interface: GigabitEthernet0/0
Temp  sub net mask: 255.255.248.0
   DHCP Lease server: 78.107.63.102, state: 5 Bound
   DHCP transaction id: 19EA
   Lease: 973148 secs,  Renewal: 486574 secs,  Rebind: 851504 secs
Temp ip static route0: dest 195.14.50.26 router 10.111.0.1
Temp ip static route1: dest 195.14.50.16 router 10.111.0.1
   Next timer fires after: 5d15h
   Retry count: 0   Client-ID: cisco-a493.4cba.00a0-Gi0/0
   Client-ID hex dump: 636973636F2D613439332E346362612E
                       303061302D4769302F30
   Hostname: cisco-router-1941

cisco-router-1941# show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         10.111.0.8      YES DHCP   up                    up
GigabitEthernet0/1         192.168.1.1     YES manual up                    up  

Подготовка роутера к созданию l2tp соединения:

cisco-router-1941# conf t
cisco-router-1941(config)# l2tp-class DEFAULT-L2TP-CLASS
cisco-router-1941(config-l2tp-class)# end
cisco-router-1941# conf t
cisco-router-1941(config)# pseudowire-class PW-L2TP-GigabitEthernet0/0
cisco-router-1941(config-pw-class)# encapsulation l2tpv2
cisco-router-1941(config-pw-class)# protocol l2tpv2 DEFAULT-L2TP-CLASS
cisco-router-1941(config-pw-class)# ip local interface GigabitEthernet0/0
cisco-router-1941(config-pw-class)#  end

Создание туннельного интерфейса Virtual-PPP1:

cisco-router-1941# conf t
cisco-router-1941(config)# interface Virtual-PPP1
cisco-router-1941(config-if)# description ISP-External-Internet
cisco-router-1941(config-if)# ip mtu 1460
cisco-router-1941(config-if)# ip tcp adjust-mss 1420

– Данная функция позволяет предотвратить атаки связанные с фрагментацией пакетов, приводящая к переполнению буфера . Когда атакующим посылаются много незаконченных фрагментрированных пакетов и фаерволлу приходится их собирать, тратя на это память и время. В IOS с поддержкой безопасности включена по умолчанию.

cisco-router-1941(config-if)# no ip virtual-reassembly

– Если дать команду no peer neighbor-route, то перестанет работать механизм ipcp, т.е. не будут автоматически прописаны маршруты по-умолчанию, нужно будет их прописать самостоятельно. Узнать можно, например, посмотрев на компьютере, подключенному к сети напрямую, получившим эти маршруты. Или где-то на сайте билайна.

cisco-router-1941(config-if)# no peer neighbor-route
cisco-router-1941(config-if)# no cdp enable
cisco-router-1941(config-if)# ip address negotiated
cisco-router-1941(config-if)# no ppp authentication chap callin


– В следующих 2-х командах, нужно руками вводить свой логин и пароль для доступа в интернет.

cisco-router-1941(config-if)# ppp chap hostname 'your-login'
cisco-router-1941(config-if)# ppp chap password 'your-pass'

– Ну почему нельзя ввести какое-нибудь dns имя вместо IP?


– cisco-router-1941(config-if)# pseudowire <l2tp server> 10 pw-class PW-L2TP-GigabitEthernet0/0

cisco-router-1941(config-if)# pseudowire 85.21.0.241 10 pw-class PW-L2TP-GigabitEthernet0/0
cisco-router-1941(config-if-xconn)# end

– Virtual-PPP1 присвоен ожидаемый IP адрес.

cisco-router-1941# show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         10.111.0.8      YES DHCP   up                    up
GigabitEthernet0/1         192.168.1.2     YES NVRAM  up                    up
Virtual-PPP1               95.31.31.8      YES IPCP   up                    up  

Проверка работы интернета на маршрутизаторе

– Проверили локалку

cisco-router-1941#  ping beeline.ru
Translating "beeline.ru"...domain server (85.21.192.3) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 217.118.87.98, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

– Проверили Интернет

cisco-router-1941#  ping ya.ru source Virtual-PPP1
Translating "ya.ru"...domain server (85.21.192.3) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 213.180.204.3, timeout is 2 seconds:
Packet sent with a source address of 95.31.31.8
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/19/80 ms

Настройка NAT

cisco-router-1941# conf t
cisco-router-1941(config)# interface GigabitEthernet0/1
cisco-router-1941(config-if)# ip nat inside

cisco-router-1941(config)# interface GigabitEthernet0/0
cisco-router-1941(config-if)# ip nat outside

cisco-router-1941(config)# interface Virtual-PPP1
cisco-router-1941(config-if)# ip nat outside

cisco-router-1941(config-if)#exit

– Листы доступа

cisco-router-1941(config)# ip access-list extended nat
cisco-router-1941(config-ext-nacl)# deny ip any host 85.21.0.241
cisco-router-1941(config-ext-nacl)# permit ip 192.168.1.0 0.0.0.255 any
cisco-router-1941(config-ext-nacl)# exit

cisco-router-1941(config)# route-map public permit 10
cisco-router-1941(config-route-map)# match ip address nat
cisco-router-1941(config-route-map)# match interface Virtual-PPP1
cisco-router-1941(config-route-map)# exit

cisco-router-1941(config)# route-map local permit 10
cisco-router-1941(config-route-map)# match ip address nat
cisco-router-1941(config-route-map)# match interface GigabitEthernet0/0
cisco-router-1941(config-route-map)# exit

cisco-router-1941(config)# ip nat inside source route-map local interface GigabitEthernet0/0
cisco-router-1941(config)# ip nat inside source route-map public interface Virtual-PPP1 overload

Обязательные маршруты

cisco-router-1941(config)#ip forward-protocol nd
cisco-router-1941(config)#ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
cisco-router-1941(config)#ip route 85.21.0.241 255.255.255.255 dhcp


cisco-router-1941# show ip route

Gateway of last resort is 10.111.0.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 10.111.0.1
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
S        10.0.0.0/8 [1/0] via 10.111.0.1
C        10.111.0.0/21 is directly connected, GigabitEthernet0/0
L        10.111.0.8/32 is directly connected, GigabitEthernet0/0
      78.0.0.0/32 is subnetted, 1 subnets
S        78.107.63.102 [254/0] via 10.111.0.1, GigabitEthernet0/0
      85.0.0.0/32 is subnetted, 2 subnets
C        85.21.0.241 is directly connected, Virtual-PPP1
S        85.21.192.3 [1/0] via 10.111.0.1
      89.0.0.0/32 is subnetted, 1 subnets
S        89.179.135.67 [1/0] via 10.111.0.1
      95.0.0.0/32 is subnetted, 1 subnets
C        95.31.31.8 is directly connected, Virtual-PPP1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
L        192.168.1.2/32 is directly connected, GigabitEthernet0/1
      195.14.50.0/32 is subnetted, 2 subnets
S        195.14.50.16 [254/0] via 10.111.0.1
S        195.14.50.26 [254/0] via 10.111.0.1
      213.234.192.0/32 is subnetted, 1 subnets
S        213.234.192.8 [1/0] via 10.111.0.1


Почитать:

http://homenet.beeline.ru/index.php?showtopic=206930&st=0
http://habrahabr.ru/post/136342/

Первый Международный Позитивный Информационный портал: PPP1.ru

Первый Международный Позитивный Информационный портал: PPP1.ru ☰